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BLOCK 2 MIDDLEWARE TECHNOLOGIES
Introduction

Middleware refers to a software that acts as a bridge between an operating system or
database and applications. Three basic types of middleware are: i) communication
middleware, ii) database middleware, and iii) system middleware. Middleware has two
separate but related connotations: i) software that enables two separate programs to
interact with each other and ii) software layer inside a single application that allows
different aspects of the program to work together.

In this block we will discuss some of the commonly used software tools like office tools
and database management systems. The block also discusses the multimedia tools
covering different aspects of multimedia production and delivery.

This block has three Units:

Unit 5 on Office Tools: Word Processing, Presentation and Spreadsheets deals
with open source Office productivity tool LibreOffice covering its three components,
Writer, Impress and Calc.

Unit 6 on Database Management Systems introduces the database approach,
database management system (DBMS), database environment, database security and
some popular DBMS packages.

Unit 7 covers Multimedia discussing characteristics of Multimedia systems, design
and storyboarding aspects, tools for multimedia development, storing and retrieval and
data integrity issues.
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UNIT 5 OFFICE TOOLS: WORD
PROCESSING, PRESENTATION AND
SPREADSHEETS

Structure

5.0 Objectives

5.1 Introduction

5.2 Getting Started with LibreOffice Suit
5.2.1 Advantages of LibreOffice

5.3 Word Processing with Writer
5.3.1 Working with Text
5.3.2 Formatting Text
5.3.3 Formatting Pages
5.3.4 Using Mail Merge
5.3.5 Tracking Changes to a Document
5.3.6 Linking  to another part of a Document

5.4 Presentations with Libreoffice: Impress
5.4.1 Main Impress Window
5.4.2 Creating a New Presentation
5.4.3 Formatting a Presentation
5.4.4 Setting up a Slide Show

5.5 Spreadsheets with Libreoffice: Calc
5.5.1 Calc Main Window
5.5.2 Spreadsheet Layout
5.5.3 Opening a CSV File
5.5.4 Navigating within Spreadsheets
5.5.5 Working with Columns and Rows
5.5.6 Working with Sheets
5.5.7 Working with a Spreadsheet
5.5.8 Sorting Records
5.5.9 Using Formulas and Functions
5.5.10 Analysing Data
5.5.11 Creating a Chart

5.6 Summary

5.7 Answers to Self Check Exercises

5.8 Keywords

5.9 References and Further Reading

5.0 OBJECTIVES
After going through this Unit, you will be able to:

 understand the features of LibreOffice as a freely available, open source, fully-
featured office productivity suite;
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 use LibreOffice applications such as Writer (word processor or text editor), Impress
(presentation) and Calc (spreadsheet); and

 explain how different applications wizards in the office tools help you in handling
tasks for its various applications.

5.1 INTRODUCTION
Office tools are applications that allow viewing, creating and modifying of general
office documents (e.g letters, memos, reports, presentations, spreadsheets, image editing,
etc.). Office productivity tools also include applications for managing employee tasks.

Choosing free and open source software over proprietary software does not mean that
you compromise on features and support. Open source office tools are as feature-rich
as proprietary tools. They also provide ample online documentation and have large
communities of users and developers as support system. These office tools are generally
referred to as office suite, productivity suite, applications tools because they come as a
collection of applications mainly consisting of word processor, spreadsheet and
presentation bundled together and quite often sharing a common user interface.

With an open-source licence, LibreOffice can be freely used and distributed with no
licence worries. LibreOffice is a leading open-source office software suite for word
processing, spreadsheets, presentations, graphics, databases and more. It is available
in many languages and works on all platforms. It stores all your data in an international
open standard format and can also read and write files from other common office
software packages. It can be downloaded and used completely free of charge for any
purpose.

In this Unit you will be introduced to the LibreOffice applications: Writer (word
processing), Impress (presentation) and Calc (spreadsheet). This Unit has been adapted
as a summary from the ‘Getting Started Guide 4.2’ – the official documentation issued
by The Document Foundation, the body responsible for developing and launching
LibreOffice suite. The material is available under the terms of either the GNU General
Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative
Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version
4.0 or later for distribution and modification. The documents used are listed in the
References and Further Readings section for further reference.

5.2 GETTING STARTED WITH LIBREOFFICE SUIT
LibreOffice is a freely available, fully-featured office productivity suite. It is a powerful
open-source office suite that provides tools for all types of office tasks such as writing
texts, working with spreadsheets, creating graphics and presentations, or designing
scientific formulas. With LibreOffice, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including Microsoft
Office, then save them back to LibreOffice format. Its native file format is Open
Document Format (ODF), an open standard format that is being adopted by governments
worldwide as a required file format for publishing and accepting documents.

LibreOffice comprises several application modules designed to interact with each other.
These modules feature the same graphical user interface and similar functionality.
LibreOffice includes the following components:

Writer (word processor) – it is a full-featured word processor with page and text-
formatting capabilities. It also includes some features that are usually found only in
expensive desktop publishing applications.
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Calc (spreadsheet) – it has all of the advanced analysis, charting, and decision making
features expected from a high-end spreadsheet.

Impress (presentations) – Impress provides all the common multimedia presentation
tools, such as special effects, animation, and drawing tools. It is integrated with the
advanced graphics capabilities of LibreOffice Draw and Math components.

Draw (vector graphics)

Draw is a vector drawing tool that can produce everything from simple diagrams or
flowcharts to 3D artwork.

Base (database) – Base provides tools for day-to-day database work within a simple
interface. It can create and edit forms, reports, queries, tables, views, and relations, so
that managing a relational database is much the same as in other popular database
applications.

Math (formula editor)

Math is the LibreOffice formula or equation editor. You can use it to create complex
equations that include symbols or characters not available in standard font sets. While
it is most commonly used to create formulae in other documents, such as Writer and
Impress files, Math can also work as a standalone tool.

5.2.1 Advantages of LibreOffice
The advantages of LibreOffice over other office suites are:

 No licensing fees required – LibreOffice is free for anyone to use and distribute
at no cost. Many features like PDF export are available as extra cost add-ins in
other office suites whereas in LibreOffice it is free. There are no hidden charges
involved at present and not expected in the future as well.

 Open source – You can distribute, copy, and modify the software as much as you
wish, in accordance with the LibreOffice Open Source license policy.

 Cross-platform- LibreOffice runs on several hardware architectures and under
multiple operating systems, such as Microsoft Windows, Mac OS X and Linux.

 Extensive language support – The LibreOffice user interface is available in
over 40 languages and the LibreOffice project provides spelling, hyphenation,
and thesaurus dictionaries in over 70 languages and dialects. LibreOffice also
provides support for both Complex Text Layout (CTL) and Right to Left (RTL)
layout languages (such as Urdu, Hebrew, and Arabic).

 Consistent user interface – All the components have a similar “look and feel,”
making them easy to use and master.

 Integration – The components of LibreOffice are well integrated with one another.
They share a common spelling checker and other tools. The drawing tools for
example available in Writer are also found in Calc and with similar but enhanced
versions in Impress and Draw. Another advantage is that there is no need to know
which application was used to create a particular file. For instance one can open a
Draw file from Writer.

 Granularity – LibreOffice options can be set at a component level or even at
document level. One may change options at component level so as not to disturb
the other components.

Office Tools: Word
Processing, Presentation

and Spreadsheets
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 File compatibility – In addition to its native OpenDocument formats, LibreOffice
includes PDF and Flash export capabilities, as well as support for opening and
saving files in many common formats including Microsoft Office, HTML, XML,
WordPerfect, and Lotus 1-2-3 formats. An extension (included) provides the
ability to import and edit some PDF files.

 No vendor lock-in – LibreOffice uses OpenDocument, an XML (eXtensible
Markup Language) file format developed as an industry standard by OASIS
(Organization for the Advancement of Structured Information Standards). These
files can easily be unzipped and read by any text editor, and their framework is
open and published.

 You have a voice – Enhancements, software fixes, and release dates are community
driven. You can join the community and affect the course of the product you use.

You can read more about LibreOffice and The Document Foundation on their websites
at: http://www.libreoffice.org/ and http://www.documentfoundation.org/.

The software can be downloaded from http://www.libreoffice.org/download. For
Information on installing and setting up LibreOffice on the various supported operating
systems visit: http://www.libreoffice.org/get-help/installation/.

The most common way to launch any component of LibreOffice is by using the system
menu, the standard menu from which most applications are started. Clicking on the
LibreOffice menu entry or tile opens the LibreOffice Start Center as shown in Fig. 5.1.
From the Start Centre individual components of LibreOffice may be selected to open.
You can also select to open an existing file or use a template from the Start Centre.

Fig. 5.1: Start Centre of LibreOffice

For each component of LibreOffice, the main window is almost similar. Common features
include the menu bar, standard toolbar, and formatting toolbar at the top of the window
and the status bar at the bottom as shown in Fig. 5.2.
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Fig. 5.2: LibreOffice Standard Interface

Menu bar

The menu bar is located just below the title bar on top of the LibreOffice window. The
menu options available are: File, Edit, View, Insert, Format, Table, Tools, Window and
Help as common in other Office applications.  On selecting one of the menus, a sub-
menu drops down to show commands.

Toolbars

LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked
toolbars can be moved to different locations or made to float, and floating toolbars can
be docked. In a default LibreOffice installation, the top docked toolbar, just under the
menu bar, is called the Standard toolbar.

The second toolbar at the top, in a default LibreOffice installation, is the Formatting
bar. It is context-sensitive i.e., it shows the tools relevant to the current position of the
cursor or the object selected. For example, when the cursor is on a graphic, the
Formatting bar provides tools for formatting graphics.

Status bar

The status bar is located at the bottom of the workspace. It provides information about
the document. It is similar in Writer, Calc, Impress, and Draw, but each LibreOffice
component includes some component-specific items. An example of the Writer status
bar is shown in Fig. 5.3

Fig. 5.3: Status bar in Writer

 

Title bar 

Menu bar 

Standard toolbar 

Formatting bar 

Status bar 

Office Tools: Word
Processing, Presentation
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5.3 WORD PROCESSING WITH LIBREOFFICE:
WRITER

LibreOffice Writer is the word processor application. In addition to the usual features
of a word processor (spelling check, thesaurus, hyphenation, autocorrect, find and
replace, automatic generation of tables of contents and indexes, mail merge and others),
Writer provides the following important features:

 Templates and styles.

 Page layout methods, including frames, columns, and tables.

 Embedding or linking of graphics, spreadsheets, and other objects.

 Built-in drawing tools.

 Master documents—to group a collection of documents into a single document

 Change tracking during revisions.

 Database integration, including a bibliography database.

 Export to PDF, including bookmarks.

Apart from these above mentioned features there are many more which are relevant for
all levels of users.

5.3.1 Working with Text
Working with text (selecting, copying, pasting, moving) in Writer is similar to working
with text in any other program. LibreOffice also has some convenient ways to select
items that are not next to each other, select a vertical block of text, and paste unformatted
text.

Selecting items that are not consecutive:

1) Select the first piece of text.

2) Hold down the Ctrl key and use the mouse to select the next piece of text.

3) Repeat as often as needed.

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of
text, see the topic “Navigating and selecting with the keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in “Adding selection” mode.

3) Use the arrow keys to move to the start of the next piece of text to be selected.
Hold down the Shift key and select the next piece of text.

4) Repeat as often as required. Now Press Esc to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs
(as you might see in text pasted from e-mails, program listings, or other sources), using
LibreOffice’s block selection mode. To change to block selection mode, use Edit >
Selection Mode > Block Area, or press Ctrl+F8, or click on the Selection icon in
the Status Bar and select Block selection from the list.
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Now highlight the selection, using mouse or keyboard, as shown below.

 

Fig. 5.4: Selecting a vertical block of text

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other
applications. You can use the mouse or the keyboard for these operations. You can
copy or move text within a document, or between documents, by dragging or by using
menu selections, toolbar buttons, or keyboard shortcuts. You can also copy text from
other sources such as Web pages and paste it into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and
release it. To copy selected text, hold down the Ctrl key while dragging. The text
retains the formatting it had before dragging.

To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at
the paste-in point and use Ctrl+V to paste. Alternatively, use the buttons on the Standard
toolbar.

When you paste text, the result depends on the source of the text and how you paste it.
If you click on the Paste button, any formatting the text has (such as bold or italics) is
retained. Text pasted from Web sites and other sources may also be placed into frames
or tables. If you do not like the results, click the Undo button or press Ctrl+Z.

To make the pasted text take on the formatting of the surrounding text where it is being
pasted:

 Choose Edit > Paste Special, or

 Click the arrow button of the combination Paste button, or
 Click the Paste button without releasing the left mouse button. Then select

Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and
formatting of the text (or other object) to be pasted.

Fig. 5.5: Paste Special menu

Office Tools: Word
Processing, Presentation

and Spreadsheets
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Finding and replacing text and formatting
Writer has two ways to find text within a document: the Find toolbar for fast searching
and the Find & Replace dialog. In the dialog, you can:
 Find and replace words and phrases
 Use wildcards and regular expressions to fine-tune a search
 Find and replace specific attributes or formatting
 Find and replace paragraph styles
Using the Find & Replace dialog
To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose
Edit > Find & Replace from the Menu bar. If the Find toolbar is open, click the Find

and Replace button ( ) on the toolbar. Once opened, optionally click the Other
Options symbol to expand the dialog. Click the button again to reduce the dialog
options.
To use the Find & Replace dialog:
1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the Replace with box.
3) You can select various options such as matching the case, matching whole words

only, or doing a search for similar words.
4) When you have set up your search, click Find. To replace the found text, click

Replace.
Inserting special characters
A special character is one not found on a standard English keyboard. For example, ©
¾ æ ç ñ ö ø ¢ are all special characters. To insert a special character:
1) Place the cursor where you want the character to appear.
2) Choose Insert > Special Character to open the Special Characters dialog.
3) Select the characters (from any font or mixture of fonts) you wish to insert, in

order, then click OK. The characters selected for insertion are shown in the lower
left of the dialog. As you select a character, it is shown on the right, along with its
numerical code.

Fig. 5.6: The Special Characters dialog, where you can insert special characters
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Checking spelling and grammar

Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a wavy red line
under any unrecognised words. When the word is corrected, the line disappears.

To perform a combined spelling and grammar check on the document (or a text
selection) click the Spelling and Grammar button. This checks the document or
selection and opens the Spelling and Grammar dialog if any unrecognised words
are found. In order to use this, the appropriate dictionaries must be installed. By
default, four dictionaries are installed: a spellchecker, a grammar checker, a
hyphenation dictionary, and a thesaurus.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages
within the same document or if you write documents in various languages.

The main advantage of changing the language for a text selection is that you can then
use the correct dictionaries to check spelling and apply the localised versions of
Autocorrect replacement tables, thesaurus, grammar, and hyphenation rules.

You can also set the language for a paragraph or a group of characters as None (Do
not check spelling). This option is especially useful when you insert text such as web
addresses or programming language snippets that you do not want to check for spelling.

You can also set the language for the whole document, for individual paragraphs, or
even for individual words and characters, from Tools > Language on the Menu bar.

Another way to change the language of a whole document is to use Tools > Options >
Language Settings > Languages. In the Default languages for documents section,
you can choose a different language for all the text that is not explicitly marked as a
different language.

The spelling checker works only for those languages in the list that have the symbol
( ) next to them. If you do not see the symbol next to your preferred language, you
can install the additional dictionary using Tools > Language > More Dictionaries
Online.

The language used for checking spelling is also shown in the Status Bar, next to the
page style in use.

Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors,
which it corrects automatically. For example, “hte” will be changed to “the”.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format >
AutoCorrect > While Typing.

Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you
can define which strings of text are corrected and how. In most cases, the defaults are
fine.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word
pair, and click Delete.

Office Tools: Word
Processing, Presentation

and Spreadsheets
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To add a new spelling to the list, type it into the Replace and With boxes on the Replace
tab, and click New.

See the different tabs of the dialog for the wide variety of other options available to
fine-tune AutoCorrect.

5.3.2 Formatting Text
Styles are central to using Writer. Styles enable you to easily format your document
consistently, and to change the format with minimal effort. A style is a named set of
formatting options. When you apply a style, you apply a whole group of formats at the
same time. In addition, styles are used by LibreOffice for many processes, even if you
are not aware of them. For example, Writer relies on heading styles (or other styles you
specify) when it compiles a table of contents.

Writer defines several types of styles, for different types of elements: characters,
paragraphs, pages, frames, and lists.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar
and by using the Paragraph panel of the Sidebar’s Properties deck. Fig. 5.7 shows the
Formatting toolbar as a floating toolbar, customised to show only the buttons for
paragraph formatting. The appearance of the buttons may vary with your operating
system and the selection of icon size and style in Tools > Options > LibreOffice >
View.

1 Open Styles and 5 Align Right 10 Numbering On/Off
Formatting Window 6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1 12 Decrease Indent

3 Align Left 8 Line Spacing: 1.5 13 Increase Indent

4 Centered 9 Line Spacing: 2 14 Paragraph format dialog

Fig. 5.7: Formatting toolbar, showing buttons for paragraph formatting

Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar.
Fig. 5.8 shows the Formatting toolbar, customised to include only the buttons for
character formatting. The Character panel of the Sidebar’s Properties deck also provides
buttons for character formatting.

The appearance of the buttons may vary with your operating system and the selection
of icon size and style in Tools > Options > LibreOffice > View.
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1. Open Styles and 6. Italic 11. Reduce Font
     Formatting Window

2. Apply Style 7. Underline 12. Font Colour

3. Font Name 8. Superscript 13. Highlighting

4. Font Size 9. Subscript 14. Background Colour

5. Bold 10. Increase Font 15. Open Character Format Dialog

Fig. 5.8: Formatting toolbar, showing buttons for character formatting

Autoformatting

You can set Writer to automatically format parts of a document according to the choices
made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).

Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:

 Use autoformatting, as described above.

 Use list (numbering) styles.

 Use the Numbering and Bullets buttons on the Formatting toolbar

Using the Bullets and Numbering toolbar

You can create nested lists (where one or more list items has a sub-list under it, as in an
outline)  by using the buttons on the Bullets and Numbering toolbar (Fig. 5.9). You can
move items up or down the list, create sub-points, change the style of bullets, and
access the Bullets and Numbering dialog, which contains more detailed controls. Use
View > Toolbars > Bullets and Numbering to see the toolbar.

1 Promote One Level 5 Insert Unnumbered Entry 8 Move Up with Subpoints

2 Demote One Level 9 Move Down with Subpoints 10 Restart Numbering

3 Promote One Level 6 Move Up 11 Bullets and Numbering
with Subpoints

4 Demote One Level 7 Move Down
with Subpoints

Fig. 5.9: Bullets and Numbering toolbar

5.3.3  Formatting Pages
Writer provides several ways for you to control page layouts: page styles, columns,
frames, tables, and sections.

Office Tools: Word
Processing, Presentation

and Spreadsheets
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The best layout method depends on what the final document should look like and what
sort of information will be in the document. Here are some examples.

For a book with one column of text,
some figures without text beside them,
and some other figures with descriptive
text, use page styles for basic layout,
and tables to place figures beside
descriptive text when necessary.

For an index or other document with
two columns of text, where the text
continues from the left-hand column
to the right-hand column and then to
the next page, all in sequence (also
known as “snaking columns” of text),
use page styles (with two columns).
If the title of the document (on the
first page) is full-page width, put it in
a single-column section.

For a newsletter with complex layout,
two or three columns on the page,
and some articles that continue from
one page to some place several
pages later, use page styles for basic
layout. Place articles in linked frames
and anchor graphics to fixed positions
on the page if necessary.
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For a document with terms and
translations to appear side-by-side
in what appear to be columns, use a
table to keep items lined up, and so
you can type in both “columns”.

Creating headers and footers

A header is an area that appears at the top of a page above the margin. A footer
appears at the bottom of the page below the margin. Information such as page numbers
inserted into a header or footer displays on every page of the document with that page
style.

To insert a header, you can either:

 Choose Insert > Header > Default Style (or some other page style, if not
Default Style), or

 Click above the top margin to make the Header marker appear (Fig. 5.10), and
then click on the +.

 

Fig. 5.10: Header marker at top of text area

After a header has been created, a down-arrow appears on the header marker. Click
on this arrow to drop down a menu of choices for working with the header (Fig. 5.11).

 

Fig. 5.11: Header menu

To format a header, you can use either the menu item shown in Figure 26 or Format >
Page > Header. Both methods take you to the same tab on the Page Style dialog.

Other information such as document titles and chapter titles is often put into the header
or footer. These items are best added as fields. That way, if something changes, the
headers and footers are updated automatically. Here is one common example.

To insert the document title into the header:

1) Choose File > Properties > Description and type a title for your document.

Office Tools: Word
Processing, Presentation

and Spreadsheets
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2) Add a header (Insert > Header > Default).

3) Place the cursor in the header part of the page.

4) Choose Insert > Fields > Title. The title should appear on a gray background
(which does not show when printed and can be turned off).

5) To change the title for the whole document, go back to File > Properties >
Description.

Changing page margins

You can change page margins in three ways:

 Using the page rulers—quick and easy, but does not have fine control

 Using the Page Style dialog—can specify margins to two decimal places

 Using the Page panel on the Properties deck of the Sidebar

To change margins using the rulers:

1) The gray sections of the rulers are the margins. Put the mouse cursor over the line
between the gray and white sections. The pointer turns into a double-headed
arrow and displays the current setting in a tool-tip.

2) Hold down the left mouse button and drag the mouse to move the margin.

Fig. 5.12: Moving the margins

To change margins using the Page Style dialog:

1) Right-click anywhere in the text area on the page and select Page from the context
menu.

2) On the Page tab of the dialog, type the required distances in the Margins boxes.

To change margins using the Page panel of the Properties deck of the Sidebar:

1) On the open Sidebar (View > Sidebar) select the Properties tab.

2) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title

3) Click the Margin button to open the sub-panel and enter the required dimensions
in the Custom size boxes (clicking the More Options button will open the Page
Style dialog).

5.3.4 Using Mail Merge
Writer provides very useful features to create and print:

 Multiple copies of a document to send to a list of different recipients (form letters)
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 Mailing labels

 Envelopes

All these facilities use a registered data source (a spreadsheet or database containing
the name and address records and other information).

5.3.5 Tracking Changes to a Document
You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, or
under a different name, or both), then use Writer to combine the two files and
show the differences. Choose Edit > Compare Document. This technique is
particularly useful if you are the only person working on the document, as it avoids
the increase in file size and complexity caused by the other methods.

2) Save versions that are stored as part of the original file. However, this method can
cause problems with documents of non-trivial size or complexity, especially if you
save a lot of versions. Avoid this method if you can.

3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show
where you have added or deleted material, or changed formatting. Choose Edit >
Changes > Record before starting to edit. Later, you or another person can
review and accept or reject each change. Choose Edit > Changes > Show.
Right-click on an individual change and choose Accept Change or Reject Change
from the context menu, or choose Edit > Changes > Accept or Reject to view
the list of changes and accept or reject them.

5.3.6 Linking  to another Part of a Document
If you type in cross-references to other parts of a document, those references can
easily get out of date if you reorganize the order of topics, add or remove material, or
reword a heading. Writer provides two ways to ensure that your references are up to
date, by inserting links to other parts of the same document or to a different document:

 Hyperlinks

 Cross-references

The two methods have the same result if you Ctrl+click the link when the document is
open in Writer: you are taken directly to the cross-referenced item. However, they also
have major differences:

 The text in a hyperlink does not automatically update if you change the text of the
linked item (although you can change it manually), but changed text does
automatically update in a cross-reference.

 When using a hyperlink, you do not have a choice of the content of the link (for
example text or page number), but when using a cross-reference, you have several
choices, including bookmarks.

 To hyperlink to an object such as a graphic, and have the hyperlink show useful
text. You need to give such an object a useful name (instead of a default name like
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast,
cross- references to figures with captions automatically show useful text, and you
have a choice of several variations of the name.
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 If you save a Writer document to HTML, hyperlinks remain active but cross-
references do not. (Both remain active when the document is exported to PDF.)

Using hyperlinks

The easiest way to insert a hyperlink to another part of the same document is by using
the Navigator:

1) Open the document containing the items you want to cross-reference.

2) Open the Navigator by clicking its button, choosing View > Navigator, or by
pressing F5.

3) Click the arrow part of the combination Drag Mode button, and choose Insert
as Hyperlink.

4) In the list at the bottom of the Navigator, select the document containing the item
that you want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The
name of the item is inserted in the document as an active hyperlink.

You can also use the Hyperlink dialog to insert and modify hyperlinks within and between
documents.

Fig. 5.13: Inserting a hyperlink using the Navigator

Using cross-references

If you type in references to other parts of the document, those references can easily get
out of date if you reword a heading, add or remove figures, or reorganize topics. Replace
any typed cross- references with automatic ones and, when you update fields, all the
references will update automatically to show the current wording or page numbers. The
Cross-references tab of the  Fields dialog lists some items, such as headings, bookmarks,
figures, tables, and numbered items such as steps in a procedure. You can also create
your own reference items.

To insert a cross-reference to a heading, figure, bookmark, or other item:

1) In your document, place the cursor where you want the cross-reference to appear.
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2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-
references tab (Fig. 5.14), in the Type list, select the type of item to be referenced
(for example, Heading or Figure). You can leave this page open while you insert
many cross-references.

3) Click on the required item in the Selection list, which shows all the items of the
selected type. In the Insert reference to list, choose the format required. The list
varies according to the Type. The most commonly used options are Reference
(to insert the full text of a heading or caption), Category and Number (to insert
a figure number preceded by the word Figure or Table, but without the caption
text), Numbering (to insert only the figure or table number, without the word
“Figure” or “Table”), or Page (to insert the number of the page the referenced text
is on). Click Insert.

Fig. 5.14: The Cross-references tab of the Fields dialog

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

1) Enumerate important features of LibreOffice Writer.

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

5.4 PRESENTATIONS WITH LIBREOFFICE:
IMPRESS

Impress is the presentation (slide show) program included in LibreOffice. You can
create slides that contain many different elements, including text, bulleted and numbered
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lists, tables, charts, and a wide range of graphic objects such as clipart, drawings and
photographs. Impress also includes a spelling checker, a thesaurus, text styles, and
background styles.

To use Impress for more than very simple slide shows requires some knowledge of the
elements which the slides contain. Slides containing text use styles to determine the
appearance of that text. Creating drawings in Impress is similar to the Draw program
included in LibreOffice.

When you start Impress for the first time, the Presentation Wizard is shown. Here you
can choose from the following options:

 Empty presentation gives you a blank document

 From template is a presentation designed with a template of your choice

 Open existing presentation

 Click Create to open the main Impress window.

If you prefer not to use the Presentation Wizard in future, you can select Do not show
this wizard again. You can enable the wizard again later in Tools > Options > LibreOffice
Impress > General > New document and select the Start with wizard option.

5.4.1 Main Impress Window
The main Impress window (Fig. 5.15) has three parts: the Slides pane, Workspace,
and Sidebar. Additionally, several toolbars can be displayed or hidden during the creation
of a presentation.

Fig. 5.15: Main window of Impress; ovals indicate the Hide/Show markers

Slides pane

The Slides pane contains thumbnail pictures of the slides in your presentation, in the
order they will be shown unless you change the slide show order. Clicking a slide in this
pane selects it and places it in the Workspace. When a slide is in the Workspace, you
can make changes any way you like.

Several additional operations can be performed on one or more slides simultaneously
in the Slides pane:
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 Add new slides to the presentation.

 Mark a slide as hidden so that it will not be shown as part of the presentation.

 Delete a slide from the presentation if it is no longer needed.

 Rename a slide.

 Duplicate a slide (copy and paste) or move it to a different position in the
presentation (cut and paste).

It is also possible to perform the following operations, although there are more efficient
methods than using the Slides pane:

 Change the slide transition following the selected slide or after each slide in a
group of slides.

 Change the sequence of slides in the presentation.

 Change the slide design.

 Change slide layout for a group of slides simultaneously.

Sidebar

The Sidebar has seven sections. To expand a section you want to use, click on its icon
or click on the small triangle at the top of the icons and select a section from the drop
down list. Only one section at a time can be open.

  Properties

Shows the layouts included within Impress. You can choose the one you want and use
it as it is, or modify it to meet your own requirements. However, it is not possible to
save customised layouts.

Master Pages

Here you define the page (slide) style for your presentation. Impress includes several
designs of Master Pages (slide masters). One of them – Default – is blank, and the rest
have background and styled text.

 Custom Animation

A variety of animations can be used to emphasize or enhance different elements of each
slide. The Custom Animation section provides an easy way to add, change, or remove
animations.

 Slide Transition

Provides a number of slide transition options. The default is set to No Transition, in
which the following slide simply replaces the existing one. However, many additional
transitions are available. You can also specify the transition speed (slow, medium, fast),
choose between an automatic or manual transition, and choose how long the selected
slide should be shown (automatic transition only).

 Styles and Formatting

Here you can edit and apply graphics styles, but you can only edit presentation styles.
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When you edit a style, the changes are automatically applied to all of the elements
formatted with this style in your presentation. If you want to ensure that the styles on a
specific slide are not updated, create a new master page for the slide.

 Gallery

Opens the Impress gallery where you can insert an object into your presentation either
as a copy or as a link. A copy of an object is independent of the original object. Changes
to the original object have no effect on the copy. A link remains dependent on the
original object. Changes to the original object are also reflected in the link.

 Navigator

Opens the Impress navigator, in which you can quickly move to another slide or select
an object on a slide. It is recommended to give slides and objects in your presentation
meaningful names so that you can easily identify them when using the navigator.

Workspace

The Workspace (normally in the center of the main window) has five tabs: Normal,
Outline, Notes Handout, and Slide Sorter (Fig.5.16). These five tabs are called View
buttons. The Workspace below the View buttons changes depending on the chosen
view.

Fig.5.16: Workspace tabs

Workspace views

Each of the workspace views is designed to ease the completion of certain tasks; it is
therefore useful to familiarize yourself with them in order to quickly accomplish those
tasks. Note Each Workspace view displays a different set of toolbars when selected.
These toolbar sets can be customised by going to View > Toolbars on the Menu bar,
then check or uncheck the toolbar you want to add or remove.

Normal view

Normal view is the main view for working with individual slides. Use this view to format
and design and to add text, graphics, and animation effects.

Outline view

Outline view (Fig. 5.17) contains all the slides of the presentation in their numbered
sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in outline
format. Only the text contained in the default text boxes in each slide is shown, so if
your slide includes other text boxes or drawing objects, the text in these objects is not
displayed. Slide names are also not included.
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Fig. 5.17: Outline view

Notes view

Use the Notes view (Fig. 5.18) to add notes to a slide. These notes are not seen when
the presentation is shown.

Fig. 5.18: Notes view

1) Click the Notes tab in the Workspace.

2) Select the slide to which you want to add notes.

3) Click the slide in the Slides pane, or double-click the slide name in the Navigator.

4) In the text box below the slide, click on the words Click to add notes and begin
typing.

You can resize the Notes text box using the coloured resising handles which appear
when you click on the edge of the box. You can also move the box by placing the
pointer on the border, then clicking and dragging. To make changes in the text style,
press the F11 key to open the Styles and Formatting dialog or click on the Styles and
Formatting icon  on the Sidebar..

Handout view

Handout view is for setting up the layout of your slide for a printed handout. Click the
Handout tab in the workspace and the Layouts section opens on the Sidebar (Fig.
5.19) where you can then choose to print 1, 2, 3, 4, 6, or 9 slides per page. If the

Layouts section does not open, then click on the Properties icon  at the side of the
Sidebar. Use this view also to customize the information printed on the handout.
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Fig. 5.19: Handout layouts

Slide Sorter view

Slide Sorter view (Fig. 5.20) contains all of the slide thumbnails. Use this view to work
with a group of slides or with only one slide.

Fig. 5.20: Slide Sorter view

You can work with slides in the Slide Sorter view just as you can in the Slide pane. To
make changes, right-click a slide and choose any of the following from the context
menu:

 New Slide – adds a new slide after the selected slide.

 Duplicate Slide – creates a duplicate of the selected slide and places the new slide
immediately after the selected slide.

 Delete Slide – deletes the selected slide.

 Rename Slide – allows you to rename the selected slide.

 Slide Layout – allows you to change the layout of the selected slide.

 Slide Transition – allows you to change the transition of the selected slide.

– For one slide, select a slide and add the desired transition.

– For more than one slide, select a group of slides and add the desired transition.

 Hide Slide – any slides that are hidden are not shown in the slide show.

 Cut – removes the selected slide and saves it to the clipboard.

 Copy – copies the selected slide to the clipboard without removing it.

 Paste – inserts a slide from the clipboard after the selected slide.
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5.4.2 Creating a New Presentation
This section describes how to start a new presentation using the Presentation Wizard.

When you start Impress, the Presentation Wizard appears (Fig. 5.21).

1) Under Type, choose one of the options. These options are covered in the Impress
Guide.

– Empty presentation creates a blank presentation.

– From template uses a template design already created as the basis for a new
presentation.

The wizard changes to show a list of available templates. Choose the template you
want.

– Open existing presentation continues work on a previously created presentation.
The wizard changes to show a list of existing presentations. Choose the presentation
you want.

Fig. 5.21: Presentation Wizard

2) Click Next. Fig. 5.22 shows the Presentation Wizard step 2 as it appears if you
selected Empty Presentation at step 1. If you selected From template, an example
slide is shown in the Preview box.

Fig. 5.22: Selecting a slide design

3) Choose a design under Select a slide design. The slide design section gives you
two main choices: Presentation Backgrounds and Presentations. Each one has a
list of choices for slide designs. If you want to use one of these other than
<Original>, click it to select it.
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– The types of Presentation Backgrounds are shown in Fig. 5.22. When you select
a presentation background, you will see a preview of the slide design in the Preview
window.

– <Original> is for a blank presentation slide design.

4) Select how the presentation will be used under Select an output medium. Majority
of presentations are created for computer screen display. It is recommended to
select Screen. You can change the page format at any time.

5) Click Next and step 3 of the Presentation Wizard appears (Fig. 5.23).

– Choose the desired slide transition from the Effect drop-down menu.

– Select the desired speed for the transition between the different slides in the
presentation from the Speed drop-down menu. Medium is a good choice for
now.

Fig. 5.23: Selecting a slide transition effect

6) Click Next and step 4 of the Presentation Wizard appears allowing you to enter
information about your company and the presentation you are creating.

Fig. 5.24: Entering information about your presentation

7) Click Next and step 5 of the Presentation Wizard appears showing a preview of
what your presentation will look like (Fig. 5.25). If the preview does not appear,
select Preview.

8) If you want to create a summary of your presentation, select Create summary.

9) Click Create and your new presentation is created.
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Fig. 5.25: Presentation preview

5.4.3  Formatting a Presentation
A new presentation contains only one empty slide. In this section we will start adding
new slides and preparing them for the intended contents.

Inserting slides

New slide

A new slide can be inserted into a presentation as follows:

1) Go to Insert on the Menu bar and select Slide.

2) Or right-click on a slide in the Slides Pane or Slide Sorter view and select New
Slide from the context menu.

3) Or, right click in an empty space in the Workspace and select Slide > New Slide
from the context menu.

4) Or click the Slide icon in the Presentation toolbar. If the Presentation toolbar
is not visible, go to View > Toolbars on the Menu bar and select Presentation
from the list.

5) A new slide is inserted after the selected slide in the presentation.

Duplicate slide

Sometimes, rather than starting from a new slide you may want to duplicate a slide
already included in your presentation. To duplicate a slide:

1) Select the slide you want to duplicate from the Slides Pane.

2) Go to Insert on the Menu bar and select Duplicate Slide.

3) Or, right click on the slide in the Slides Pane or Slide Sorter view and select
Duplicate Slide from the context menu.

4) Or, right click on a slide in the Workspace and select Slide > Duplicate Slide from
the context menu.

5) Or click on the triangle to the right of the Slide icon in the Presentation
toolbar and select Duplicate Slide from the context menu. If the Presentation
toolbar is not visible, go to View > Toolbars on the Menu bar and select
Presentation from the list.

6) A duplicate slide is inserted after the selected slide in the presentation.
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Selecting slide layout

When creating a presentation, the first slide is normally a title slide. You can use either a
blank layout or one of the title layouts as your title slide. Click on the Properties icon

at the side of the Sidebar to open Layouts section and display the available layouts
(Fig. 5.26). The layouts included in LibreOffice range from a blank slide to a slide with
six contents boxes and a title.

Fig. 5.26: Available slide layouts

To create a title, if one of the title layouts has been selected, click on Click to add title
and then type the title text. To add text content, depending on the slide layout selected,
click on Click to add text.

To select or change the layout of a slide, select the slide in the Slides Pane so that it
appears in the Workspace and select the desired layout from the Layouts section in the
Sidebar. Several layouts contain one or more content boxes. Each of these content
boxes can be configured to contain text, movies, images, charts or tables. You can
choose the type of contents by clicking on the corresponding icon that is displayed in
the middle of the contents box as shown in Fig.5.27. If you intend to use the contents
box for text, click on Click to add text.

Fig.5.27: Selecting contents type
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Modifying slide elements

A slide contains elements that were included in the slide master, as well as those elements
included in the selected slide layout. However, it is unlikely that the predefined layouts
will suit all your needs for your presentation. You may want to remove elements that are
not required or insert objects such as text and graphics.

Although Impress does not have the functionality to create new layouts, it allows you to
resize and move the layout elements. It is also possible to add elements without being
limited to the size and position of the layout boxes.

To resize a contents box, click on the outer frame so that the resising handles are
displayed. To move it, place the mouse cursor on the frame so that the cursor changes
shape. You can now click and drag the contents box to a new position on the slide.

To remove any unwanted elements:

1) Click the element to highlight it. The resising handles show it is selected.

2) Press the Delete key to remove it.

Adding text

To add text to a slide that contains a text frame, click on Click to add text in the text
frame and then type your text. The Outline styles are automatically applied to the text as
you insert it. You can change the outline level of each paragraph as well as its position
within the text by using the arrow buttons on the Text Formatting toolbar.

Adding objects

To add any objects to a slide, for example a picture, clipart, drawing, photograph, or
spreadsheet, click on Insert then select from the drop down menu what type of object
you want to insert.

Modifying appearance of all slides

To change the background and other characteristics of all slides in the presentation, you
need to modify the master page or choose a different master page. A Slide Master is a
slide with a specified set of characteristics that acts as a template and is used as the
starting point for creating other slides. These characteristics include slide background,
objects in the background, formatting of any text used, and any background graphics.

5.4.4 Setting up a Slide Show
Impress allocates reasonable default settings for slide shows, while at the same time
allowing for customising many aspects of the slide show experience.

Most of the tasks are best done in Slide Sorter view where you can see most of the
slides simultaneously. Go to View > Slide Sorter on the Menu bar or click the Slide
Sorter tab at the top of the Workspace.

One slide set – multiple presentations

In many situations, you may find that you have more slides than the time available to
present them or you may want to provide a rapid overview without dwelling on the
details. Rather than having to create a new presentation, you can use two tools that
Impress offers: hiding slides and custom slide shows.
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Hiding slides

1) Select the slide you want to hide in the Slide Pane or Slide Sorter view on the
Workspace area.

2) Go to Slide Show > Hide Slide on the Menu bar or right-click on the slide
thumbnail and select Hide Slide from the context menu. Hidden slides are marked
by a diagonal bars across the slide.

Custom slide shows

If you want to create a custom slide show from the same presentation:

1) Select the slides you want to use in your custom slide show.

2) Go to Slide Show > Custom Slide Show on the Menu bar.

3) Click on the New button to create a new sequence of slides and save it with a
different name. You can have as many slide shows as you want from a single
presentation.

Slide transitions

Slide transition is the animation that is played when a slide is changed for the next slide
in your presentation. You can configure the slide transition from the Slide Transition
section in the Tasks Pane.

1) Go to Slide Show > Slide Transition on the Menu bar or click on the Slide
Transition icon on the Sidebar to open the options available for slide transitions.

2) Select the desired transition, the speed of the animation, and whether the transition
should happen when you click the mouse (preferred) or automatically after a certain
number of seconds.

Running a slide show

To run a slide show, do one of the following:

 Click Slide Show > Start from first Slide on the Menu bar.

 Click the Start from first Slide icon on the Presentation toolbar.

 Press F5 on the keyboard.

If the slide advance is set to Automatically after X sec, let the slide show run by itself.
If the slide advance is set to On mouse click, do one of the following to move from one
slide to the next:

 Use the arrow keys on the keyboard to go to the next slide or to go back to the
previous one.

 Click the mouse to move to the next slide.

 Press the spacebar on the keyboard to advance to the next slide.

Right-click anywhere on the screen to open a context menu where you can navigate
through the slides and set other options.
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To exit the slide show at any time including when the slide show has ended, press the
Esc key.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

2) Discuss the steps in running a slide show.

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

5.5 SPREADSHEETS WITH LIBREOFFICE: CALC
Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical)
in a spreadsheet and then manipulate this data to produce certain results.

Other features provided by Calc include:

 Functions, which can be used to create formulas to perform complex calculations
on data.

 Database functions, to arrange, store, and filter data.

 Dynamic charts; a wide range of 2D and 3D charts.

 Macros, for recording and executing repetitive tasks; scripting languages supported
Include LibreOffice Basic, Python, BeanShell, and JavaScript.

 Ability to open, edit, and save Microsoft Excel spreadsheets.

  Import and export of spreadsheets in multiple formats, including HTML, CSV,
PDF, and PostScript.

Calc works with elements called spreadsheets. Spreadsheets consist of a number of
individual sheets, each sheet containing cells arranged in rows and columns. A particular
cell is identified by its row number and column letter. Cells hold the individual elements
– text, numbers, formulas, and so on – that make up the data to display and manipulate.
Each spreadsheet can have several sheets, and each sheet can have several individual
cells. In Calc, each sheet can have a maximum of 1,048,576 rows (65,536 rows in
Calc 3.2 and earlier) and a maximum of 1024 columns.

5.5.1 Calc Main Window
When Calc is started, the main window opens as shown in Fig. 5.28.

Office Tools: Word
Processing, Presentation

and Spreadsheets



Middleware Technologies

3 4

Fig. 5.28: Calc main dialog, without Sidebar

Formula bar is a special component of the Calc which is not common with other
LibreOffice applications is described below.
Formula bar
The Formula Bar is located at the top of the sheet in the Calc workspace. The Formula
Bar is permanently docked in this position and cannot be used as a floating toolbar. If
the Formula Bar is not visible, go to View on the Menu bar and select Formula Bar.

Fig. 5.29: Formula bar

Going from left to right and referring to Figure 2, the Formula Bar consists of the
following:
 Name Box – gives the cell reference using a combination of a letter and number,

for example A1. The letter indicates the column and the number indicates the row
of the selected cell.

 Function Wizard  – opens a dialog from which you can search through a list
of available functions. This can be very useful because it also shows how the
functions are formatted.

 Sum   – clicking on the Sum icon totals the numbers in the cells above the
selected cell and then places the total in the selected cell. If there are no numbers
above the selected cell, then the cells to the left are totalled.

Function = – clicking on the Function icon inserts an equals (=) sign into the selected
cell and the Input line, allowing a formula to be entered.
 Input line – displays the contents of the selected cell (data, formula, or function)

and allows you to edit the cell contents.
 You can also edit the contents of a cell directly in the cell itself by double-clicking

on the cell. When you enter new data into a cell, the Sum and Function icons
change to Cancel and Accept  icons .

5.5.2  Spreadsheet Layout
Individual cells

The main section of the workspace in Calc displays the cells in the form of a grid. Each
cell is formed by the intersection of the columns and rows in the spreadsheet.
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At the top of the columns and the left end of the rows are a series of header boxes
containing letters and numbers. The column headers use an alpha character starting at A
and go on to the right. The row headers use a numerical character starting at 1 and go
down.

These column and row headers form the cell references that appear in the Name Box
on the Formula Bar (Figure 2). If the headers are not visible on your spreadsheet, go to
View on the Menu bar and select Column & Row Headers.

Sheet tabs

In Calc you can have more than one sheet in a spreadsheet. At the bottom of the grid of
cells in a spreadsheet are sheet tabs indicating how many sheets are there in your
spreadsheet. Clicking on a tab enables access to each individual sheet and displays that
sheet. An active sheet is indicated with a white tab (default Calc setup). You can also
select multiple sheets by holding down the Ctrl key while you click on the sheet tabs.

5.5.3  Opening a CSV File
Comma-separated-values (CSV) files are spreadsheet files in a text format where cell
contents are separated by a character, for example a comma or semi-colon. Each line
in a CSV text file represents a row in a spreadsheet. Text is entered between quotation
marks; numbers are entered without quotation marks.

To open a CSV file in Calc:

1) Choose File > Open on the Menu bar and locate the CSV file that you want to
open.

2) Select the file and click Open. By default, a CSV file has the extension .csv.
However, some CSV files may have a .txt extension.

3) The Text Import dialog (Fig. 5.30) opens allowing you to select the various
options available when importing a CSV file into a Calc spreadsheet.

4) Click OK to open and import the file.

Fig. 5.30: Text Import dialog
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The various options for importing CSV files into a Calc spreadsheet are as follows:

 Import

– Character Set – specifies the character set to be used in the imported file.

– Language – determines how the number strings are imported.

If Language is set to Default for CSV import, Calc will use the globally set language. If
Language is set to a specific language, that language will be used when importing numbers.

– From Row – specifies the row where you want to start the import. The rows are
visible in the preview window at the bottom of the dialog.

 Separator Options – specifies whether your data uses separators or fixed widths
as delimiters.

– Fixed width – separates fixed-width data (equal number of characters) into
columns. Click on the ruler in the preview window to set the width.

– Separated by – select the separator used in your data to delimit the data into
columns.

When you select Other, you specify the character used to separate data into columns.
This custom separator must also be contained in your data.

– Merge delimiters – combines consecutive delimiters and removes blank data
fields.

– Text delimiter – select a character to delimit text data.

 Other options

– Quoted fields as text – when this option is enabled, fields or cells whose values
are quoted in their entirety (the first and last characters of the value equal the text
delimiter) are imported as text.

– Detect special numbers – when this option is enabled, Calc will automatically
detect all number formats, including special number formats such as dates, time,
and scientific notation.

The selected language also influences how such special numbers are detected, since
different languages and regions many have different conventions for such special numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The
rest, including numbers formatted in scientific notation, will be imported as text. A decimal
number string can have digits 0-9, thousands separators, and a decimal separator.
Thousands separators and decimal separators may vary with the selected language and
region.

 Fields – shows how your data will look when it is separated into columns.

– Column type – select a column in the preview window and select the data type to
be applied the imported data.

– Standard – Calc determines the type of data.

– Text – imported data are treated as text.

– US English – numbers formatted in US English are searched for and included
regardless of the system language. A number format is not applied. If there are no
US English entries, the Standard format is applied.
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– Hide – the data in the column are not imported.

5.5.4  Navigating within Spreadsheets
Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to
sheet. You can generally use the method you prefer.

Cell navigation

When a cell is selected or in focus, the cell borders are emphasised. When a group of
cells is selected, the cell area is coloured. The colour of the cell border emphasis and
the colour of a group of selected cells depend on the operating system being used and
how you have set up LibreOffice.

 Using the mouse – place the mouse pointer over the cell and click the left mouse
button.

To move the focus to another cell using the mouse, simply move the mouse pointer
to the cell where you want the focus to be and click the left mouse button.

 Using a cell reference – highlight or delete the existing cell reference in the
Name Box on the Formula Bar (Fig. 5.29). Type the new cell reference of the cell
you want to move to and press Enter key. Cell references are case-insensitive: for
example, typing either a3 or A3 will move the focus to cell A3.

Using the Navigator – click on the Navigator icon  on the Standard toolbar or
press the F5 key to open the Navigator dialog (Fig. 5.31) or click the Navigator Tab
button in the open Sidebar. Type the cell reference into the Column and Row fields and
press the Enter key.

 Using the Enter key – pressing Enter moves the cell focus down in a column to
the next row. Pressing Shift+Enter moves the focus up in a column to the next
row.

 Using the Tab key – pressing Tab moves the cell focus right in a row to the next
column.

Pressing Shift+Tab moves the focus to the left in a row to the next column.

 Using the arrow keys – pressing the arrow keys on the keyboard moves the cell
focus in the direction of the arrow pressed.

Fig. 5.31: Navigator dialog in Calc

Office Tools: Word
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 Using Home, End, Page Up and Page Down

– Home moves the cell focus to the start of a row.

– End moves the cell focus to the last cell on the right in the row that contains
data.

– Page Down moves the cell focus down one complete screen display.

– Page Up moves the cell focus up one complete screen display.

Sheet navigation

Each sheet in a spreadsheet is independent of the other sheets in a spreadsheet, though
references can be linked from one sheet to another sheet. There are three ways to
navigate between different sheets in a spreadsheet.

 Using the Navigator – when the Navigator is open (Fig. 5.31), double-clicking
on any of the listed sheets selects the sheet.

 Using the keyboard – using key combinations Ctrl+Page Down moves one
sheet to the right and Ctrl+Page Up moves one sheet to the left.

 Using the mouse – clicking on one of the sheet tabs at the bottom of the
spreadsheet selects that sheet.

If your spreadsheet contains a lot of sheets, then some of the sheet tabs may be hidden
behind the horizontal scroll bar at the bottom of the screen. If this is the case:

 Using the four buttons to the left of the sheet tabs can move the tabs into view (Fig.
5.32).

 Dragging the scroll bar edge to the right may reveal all the tabs.

 Right-clicking on any of the arrows opens a context menu where you can select a
sheet (see Fig. 5.33).

Fig. 5.32: Navigating sheet tabs

Fig. 5.33: Right-click any arrow button
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5.5.5 Working with Columns and Rows
Inserting columns and rows

When you insert a column, it is inserted to the left of the highlighted column. When you
insert a row, it is inserted above the highlighted row. When you insert columns or rows,
the cells take the formatting of the corresponding cells in the next column to left or the
row above.

Single column or row

Using the Insert menu:

1) Select a cell, column, or row where you want the new column or row inserted.

2) Go to Insert on the Menu bar and select either Insert > Columns or Insert >
Rows.

Using the mouse:

1) Select a column or row where you want the new column or row inserted.

2) Right-click the column or row header.

3) Select Insert Columns or Insert Rows from the context menu.

Multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting them one at a
time.

1) Highlight the required number of columns or rows by holding down the left mouse
button on the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows

Single column or row

To delete a single column or row:

1) Select a cell in the column or row you want to delete.

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select
Delete from the context menu.

3) Select the option you require from the Delete Cells dialog (Fig. 5.34).

Fig. 5.34: Delete Cells dialog

Alternatively:

1) Click in the column or header to select the column or row.

Office Tools: Word
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2) Go to Edit on the Menu bar and select Delete Cells or right-click and select
Delete Columns or Delete Rows from the context menu.

Multiple columns or rows

To delete multiple columns or rows:

1) Select the columns or rows

2) Go to Edit on the Menu bar and select Delete Cells or right-click and select
Delete Columns or Delete Rows from the context menu.

5.5.6 Working with Sheets
Click on the Add Sheet icon . This inserts a new sheet after the last sheet in the
spreadsheet without opening the Insert Sheet dialog. You can move or copy sheets
within the same spreadsheet by dragging and dropping or using the Move/Copy Sheet
dialog. To move or copy a sheet into a different spreadsheet, you have to use the
Move/Copy Sheet dialog.

Using a dialog

Use the Move/Copy Sheet dialog (Fig. 5.35) to specify exactly whether you want the
sheet in the same or a different spreadsheet, its position within the spreadsheet, the
sheet name when you move or copy the sheet.

1) In the current document, right-click on the sheet tab you wish to move or copy
and select Move/Copy Sheet from the context menu or go to Edit > Sheet >
Move/Copy on the Menu bar.

2) Select Move to move the sheet or Copy to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-
down list in To document. This can be the same spreadsheet, another spreadsheet
already open, or you can create a new spreadsheet.

4) Select the position in Insert before where you want to place the sheet.

5) Type a name in the New name text box if you want to rename the sheet when it is
moved or copied. If you do not enter a name, Calc creates a default name (Sheet
1, Sheet 2, and so on).

6) Click OK to confirm the move or copy and close the dialog.

 

Fig. 5.35: Insert Sheet dialog
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Deleting sheets

To delete a single sheet, right-click on the sheet tab you want to delete and select
Delete Sheet from the context menu, or go to Edit > Sheet > Delete from on the
Menu bar. Click Yes to confirm the deletion.

5.5.7  Working with a Spreadsheet
Entering Numeric Data

Click in the cell and type in the number using the number keys on either the main
keyboard or the numeric keypad. To enter a negative number, either type a minus (–)
sign in front of it or enclose it in parentheses (brackets), like this: (1234). By default,
numbers are right-aligned and negative numbers have a leading minus symbol.

Entering Text

Click in the cell and type the text. Text is left-aligned by default. If a number is entered
in the format 01481, Calc will drop the leading 0. To preserve the leading zero, for
example for telephone area codes, type an apostrophe before the number, like this:
‘01481. The data is now treated as text and displayed exactly as entered.

Using the Fill Tool on cells

At its simplest, the Fill tool is a way to duplicate existing content. Start by selecting the
cell to copy, then drag the mouse in any direction (or hold down the Shift key and click
in the last cell you want to fill), and then choose Edit > Fill and the direction in which you
want to copy: Up, Down, Left or Right. A more complex use of the Fill tool is to add a
fill series to a spreadsheet, select the cells to fill, choose Edit > Fill > Series.

Formatting Numbers

Several different number formats can be applied to cells by using icons on the Formatting
toolbar. Select the cell, then click the relevant icon. Some icons may not be visible in a
default setup; click the down-arrow at the end of the Formatting bar and select other
icons to display.

5.5.8 Sorting Records
Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify.
Several criteria can be used and a sort applies each criteria consecutively. Sorts are
useful when you are searching for a particular item and become even more useful after
you have filtered data.

Also, sorting is useful when you add new information to your spreadsheet. When a
spreadsheet is long, it is usually easier to add new information at the bottom of the
sheet, rather than adding rows in their correct place. After you have added information,
you then carry out a sort to update the spreadsheet.

Fig. 5.36: Sort Criteria dialog
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To sort cells in your spreadsheet:

1) Select the cells to be sorted.

2) Go to Data > Sort on the Menu bar to open the Sort dialog (Fig. 5.36).

3) Select the sort criteria from the drop down lists. The selected lists are populated
from the selected cells.

4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).

5) Click OK and the sort is carried out on your spreadsheet.

5.5.9 Using Formulas and Functions
You may need more than numbers and text on your spreadsheet. Often the contents of
one cell depend on the contents of other cells. Formulas are equations that use numbers
and variables to produce a result. Variables are placed in cells to hold data required
equations.

A function is a predefined calculation entered in a cell to help you analyze or manipulate
data. All you have to do is enter the arguments and the calculation is automatically made
for you. Functions help you create the formulas required to get the results that you are
looking for.

5.5.10 Analysing Data
Calc includes several tools to help you analyze the information in your spreadsheets,
ranging from features for copying and reusing data, to creating subtotals automatically,
to varying information to help you find the answers you need. These tools are divided
between the Tools and Data menus.

One of the most useful of these tools is the PivotTable, which is used for combining,
comparing, and analysing large amounts of data easily. Using the PivotTable, you can
view different summaries of the source data, display the details of areas of interest, and
create reports, whether you are a beginner, an intermediate or advanced user.

5.5.11 Creating a Chart
Chart is a useful tool for quantitative analysis and representation of a data series in a
performance report or a presentation. It is also visually appealing to the laymen for
understanding various data elements.

To create a chart, you will first highlight (select) the data to be included in the chart. The
selection does not need to be in a single block, as shown in Fig. 5.37; you can also
choose individual cells or groups of cells (columns or rows).

Fig. 5.37: Selecting Data for Plotting
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Next, open the Chart Wizard dialog using one of two methods.

 Choose Insert > Chart from the menu bar.

 Or, click the Chart icon on the main toolbar.

Fig. 5.38: Insert Chart from Main Toolbar

Either method inserts a sample chart on the worksheet, opens the Formatting toolbar,
and opens the Chart Wizard, as shown in Fig. 5.39.

Fig. 5.39: Chart Wizard

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

3) Explain steps in sorting data in Calc.

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

5.6 SUMMARY
In this Unit you have been introduced to an open source office productivity tool
LibreOffice. The special features of LibreOffice have been discussed in this Unit. In the
section on Word processing in with Writer you were introduced to working with text,
formatting using mail merge, tracking changes and linking to other parts of a document.
In Impress you learned about the structure, creating and formatting presentation and
setting up a slide show. Finally in the Calc section you were introduced to Calc main
window and the spreadsheet layout. Importing data in CSV format, navigating within

Office Tools: Word
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spreadsheet, working with columns and  rows as well as spreadsheets, sorting records,
using formula and functions, analysing data and graphical presentation of data in Calc
has also been covered. The Unit has been presented in a manual format to help you in
getting started with LibreOffice.

5.7 ANSWERS TO SELF CHECK EXERCISES
1) Writer provides the following important features:

 Templates and styles.

 Page layout methods, including frames, columns, and tables.

 Embedding or linking of graphics, spreadsheets, and other objects.

 Built-in drawing tools.

 Master documents—to group a collection of documents into a single document

 Change tracking during revisions.

 Database integration, including a bibliography database.

 Export to PDF, including bookmarks.

2) To run a slide show, do one of the following:

 Click Slide Show > Start from first Slide on the Menu bar.

 Click the Start from first Slide icon on the Presentation toolbar.

 Press F5 on the keyboard.

If the slide advance is set to Automatically after X sec, let the slide show run by itself.
If the slide advance is set to On mouse click, do one of the following to move from one
slide to the next:

 Use the arrow keys on the keyboard to go to the next slide or to go back to the
previous one.

 Click the mouse to move to the next slide.

 Press the spacebar on the keyboard to advance to the next slide.

Right-click anywhere on the screen to open a context menu where you can navigate
through the slides and set other options.

3) To sort cells in your spreadsheet:

a) Select the cells to be sorted.

b) Go to Data > Sort on the Menu bar to open the Sort dialog.

c) Select the sort criteria from the drop down lists. The selected lists are populated
from the selected cells.

d) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).

e) Click OK and the sort is carried out on your spreadsheet.
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5.8 KEYWORDS

BeanShell : Java-like scripting language, invented by Patrick
Niemeyer. It  runs in the Java Runtime
Environment (JRE) and uses Java syntax, in
addition to scripting commands and syntax.

Complex Text Layout : Typesetting of writing systems in which the shape
or positioning of a grapheme depends on its
relation to other graphemes. The term is used in
the field of software internationalization, where
each grapheme is a character.

CSV : A common, relatively simple file format that is
widely supported by consumer, business, and
scientific applications.

JavaScript : An object-oriented computer programming
language commonly used to create interactive
effects within web browsers.

Open source software : Software for which the original source code is
made freely available and may be redistributed
and modified.

Python : A high-level general-purpose programming
language.
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6.0 OBJECTIVES
After going through this Unit, you should be able to:

 appreciate the limitations of the traditional approach to application system
development;

 give reasons why the database approach is now being increasingly adopted;

 discuss different views of data;

 list the components of a database management system;

 enumerate the features and capabilities of a database management system; and

 discuss the security threats for the DBMS and their counter measures.

6.1 INTRODUCTION
We all live in an age where the world is full of data and information. Everyone is aware
of Internet, which has become a huge source of information and also growing everyday.
The amount of data is actually very large to access and maintain.

For example, if we go to the bank to deposit or withdraw funds, if we make booking in
a hotel or railways reservation, even purchasing items from a supermarket or Mall, all
these activities involves an automatic update of the database which keeps the inventory
of the store room or showroom items.

Relational database systems have become increasingly popular since the late 1970’s.
They offer a powerful method for storing data in an application-independent manner.
This means that for many enterprises the database is at the core of the IT strategy.
Developments can progress around a relatively stable database structure which is secure,
reliable, efficient, and transparent.

In early systems, each suite of application programs had its own independent master
file. The duplication of data over master files could lead to inconsistent data. Efforts to
use a common master file for a number of application programs resulted in problems of
integrity and security. The production of new application programs could require
amendments to existing application programs, resulting in unproductive maintenance.

Data structuring techniques, developed to exploit random access storage devices,
increased the complexity of the insert, delete and update operations on data. As a first
step towards a DBMS, packages of subroutines were introduced to reduce programmer
effort in maintaining these data structures. However, the use of these packages still
requires knowledge of the physical organisation of the data. In the traditional database
applications, most of the information was stored and accessed in either textual or numeric
form. But nowadays, video clips, pictures files, weather data, satellite images and sound
image files are stored in separate and specialised databases such as multimedia databases.

In this unit we will introduce basic concepts of file oriented approach, drawbacks with
file oriented approach, database approach, use of DBMS, levels of abstraction of
DBMS, types of DBMS and security features.

6.2 FILE ORIENTED APPROACH
A file based system is a collection of application programs that perform services for the
users wishing to access information. For each application a separate master file and its
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own set of personal files were present. Each program within a file based system defines
and manages its own data. Because of this, there are certain limits as to how that data
can be used or transported. File based systems were developed as better alternatives
to paper based filing systems. By having files stored on computers, the data could be
accessed more efficiently. It was common practice for larger companies to have each
of its departments looking after its own data. The problems that arise with this type of
file based system are listed below:

 Data separation and isolation

 Limited Data Sharing – No centralised control of data.

 Program Data dependence – All programs maintain metadata for each file they
use.

 Data Redundancy (Duplication of data) – Different systems / programs have
separate copies of the same data. The same piece of information may be stored in
two or more files. For example, the particulars of an individual who may be a
customer or an employee may be stored in two or more files. Some of this
information may be changing, such as the address, the pay drawn, etc. It is therefore,
quite possible that while the address in the master file for one application has been
updated the address in the master file for another application may have not been.
It may not also be easy for the computer-based system to even find out as to in
how many files the repeating items such as the address is occurring. The solution
therefore, is to avoid this data redundancy and the keeping of multiple copies of
the same information and replace it by a system where the address is stored at just
one place physically, and is accessible by all applications from this itself.

The disadvantages of file based systems are:

 Incompatible data (different file formats).

 Lack of flexibility in organising and querying the data.

 Increased number of different application programs

 Lengthy Development times – Programmers must design their own file formats.

 Excessive Program Maintenance.

 Each Application programmer must maintain their own data.

 Each Application program needs to include code for the metadata of each file.

 Each application program must have its own processing routines for reading,
inserting, updating and deleting data

 Lack of coordination and central control.

 Problems with Data Redundancy.

 Waste of space to have duplicate data.

 Causes more maintenance headaches.

 When data changes in one file, could cause inconsistencies.

 Compromises data integrity.

These disadvantages of file based system motivate a database approach, which will be
taken in the next section for discussion.

Database Management
Systems
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6.3 DATABASE APRROACH
Having pointed out some difficulties that arise in a straight forward file-oriented approach
towards information system development, it is useful to see how the problems stated in
the earlier section can be mitigated by using the database approach.

Organisations involved in manufacturing and business or public utility services such as
hospitals, hotels, government departments, etc. would be in a position to rely into the
database approach. Some of the advantages of database approach are:

 Central Repository of shared data

 Data is managed by a controlling agent

 Stored in a standardised, convenient form

 Consistency of data

 Integrity of data

 Security of data (Unauthorised access is restricted)

 Data independence

 Allows for more analysis of the same amount of data

 Improves data access and system performance

 Potentially increases productivity

 Increases concurrency

 Provides data backups and recovery.

Some potential disadvantages of database systems are the cost of implementing them,
the amount of effort needed to transfer data into the database from a current system,
and also the impact on the whole company if the database fails (even if only for a
relatively short period). It requires DBMS software for implementation.

6.4 DATABASE AND DBMS
You have seen in the previous section the purpose for which a DBMS approach is
preferred over the conventional file based approach. Since the DBMS of an organisation
will in some sense reflect the nature of activities in the organisation, some familiarity with
the basic concepts, principles and terms used in this field are important. This section
concentrates on those components which are relevant in the context of a database
approach.

6.4.1 Database
A database is a logically coherent collection of data with some inherent meaning,
representing some aspect of real world and which is designed, built and populated with
data for a specific purpose.

6.4.2 Why Use a Database?
A database gives users access to data, which they can view, enter, or update, within the
limits of the access rights granted to them. Databases become all the more useful as the
amount of data stored continues to grow.
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A database can be local, meaning that it can be used on one machine by one user only,
or it can be distributed, meaning that the information is stored on remote machines and
can be accessed over a network. The primary advantage of using databases is that they
can be accessed by multiple users at once.

6.4.3 Database Management System (DBMS)
It is a collection of programs that enables user to create, store, modify and extract
information from a database. In other words it is general-purpose software that provides
the users with the processes of defining; constructing and manipulating the database for
various applications. There are different types of DBMSs, ranging from small systems
that run on personal computers to huge systems that run on mainframes.

The major operations that can, be performed on the database by using database software
are:

 Database Definition

 Database creation (storing data in a defined database)

 Retrieval (query and reporting)

 Update(Changing the contents of the database)

 Programming User Facilities for system development)

 Database revision and restructuring

 Database integrity control

 Performance Monitoring

The following are some of the examples of database applications:

 Computerised Library Systems

 Automated Teller Machines (ATMs)

 Flight Reservation Systems

 Railway Reservation Systems

 Inventory Management Systems

 Application Systems meant for Government Organisations

 Banking Systems

 Insurance Systems

 Hospitals and Health Sector

 Retails Markets

 Transport

 Education

 Manufacturing

 IT and BPO

 Share Business

Database Management
Systems



Middleware Technologies

5 2

6.4.4 Characteristics of Data in a Database
The data in a database should have the following characteristic features:

 Shared – Data in a database are shared among different users and applications.

 Persistence – Data in a database exist permanently in the sense the data’s life
time is beyond the scope of the process that created it.

 Validity/Integrity/Correctness – Data should be correct with respect to the
real world entity that they represent.

 Security – Data should be protected from unauthorised access.

 Consistency – Whenever more than one data element in a database represents
related to real-world values, the values should be consistent with respect to the
relationship.

 Non-Redundancy – No two data items in a database should represent the same
real-world entity.

 Independence – The three levels in the schema: internal, conceptual and external
(discussed in the later sections), should be independent of each other so that the
changes in the schema at one level should not affect the other levels.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

1) Define a DBMS. Give some examples.

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

6.5 LEVELS OF ABSTRACTION IN A DBMS
The three-level architecture forms the basis of modern database architectures. This is in
agreement with the ANSI/SPARC study group on Database Management Systems.
ANSI/SPARC is the American National Standards Institute/Standard Planning and
Requirement Committee). As shown in the figure, the architecture for DBMSs is divided
into three general levels: External, Conceptual and Internal.

Fig. 6.1: Three-level architecture
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External Level: This level is concerned with the way individual users see the data.

Conceptual level: This level can be regarded as a community user view ­ a formal
description of data of interest to the organisation, independent of any storage
considerations.

Internal level: This level is concerned with the way in which the data is actually stored.

Fig. 6.2: Working of the three- level architecture

6.5.1 External View
A user is anyone who needs to access some portion of the data. They may range from
application programmers to casual users with ad ­hoc queries. Each user has a language
at his/her disposal.

The application programmer may use any high level language or a front-end interface
while the casual user will probably use a query language.

Regardless of the language used, it will include a Data Sub­ Language DSL which is
that subset of the language which is concerned with storage and retrieval of information
in the database and may or may not be apparent to the user.

A DSL is a combination of two languages:

Data definition language (DDL) – provides for the definition or description of
database objects.

Data manipulation language (DML) – supports the manipulation or processing of
database objects.

Each user sees the data in terms of an external view: Defined by an external schema,
consisting basically of descriptions of each of the various types of external record in
that external view, and also a definition of the mapping between the external schema
and the underlying conceptual schema.

6.5.2 Conceptual View
 An abstract representation of the entire information content of the database.

 It is in general a view of the data as it actually is, that is, it is a “model” of the “real
world”

 It consists of multiple occurrences of multiple types of conceptual record, defined
in the conceptual schema.

Database Management
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 To achieve data independence, the definitions of conceptual records must involve
information content only.

 storage structure is ignored

 access strategy is ignored

 In addition to definitions, the conceptual schema contains authorisation and
validation procedures.

6.5.3 Internal View
The internal view is a low-level representation of the entire database consisting of multiple
occurrences of multiple types of internal (stored) records.

It is however at one remove from the physical level since it does not deal in terms of
physical records or blocks nor with any device specific constraints such as cylinder or
track sizes. A detail of mapping to physical storage is highly implementation specific and
is not expressed in the three-level architecture.

The internal view described by the internal schema:

 defines the various types of stored record

 what indices exist

 how stored fields are represented

 what physical sequence the stored records are in

In effect the internal schema is the storage structure definition.

Mappings

The conceptual/internal mapping:

 defines conceptual and internal view correspondence

 specifies mapping from conceptual records to their stored counterparts

 An external/conceptual mapping:

 defines a particular external and conceptual view correspondence

 A change to the storage structure definition means that the conceptual/internal
mapping must be changed accordingly, so that the conceptual schema may remain
invariant, achieving physical data independence.

A change to the conceptual definition means that the conceptual/external mapping must
be changed accordingly, so that the external schema may remain invariant, achieving
logical data independence.

6.5.4 Data Independence
The three schema architecture further explains the concept of data independence, the
capacity to change the schema at one level without having to change the schema at the
next higher level.

There are two types of data independence:

i) Logical data independence

 The ability to change the conceptual schema without having to change the external
schemas or application programs.  When data is added or removed, only the view
definition and the mappings need to be changed in the DBMS that support logical
data independence.
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 If the conceptual schema undergoes a logical reorganisation, application programs
that reference the external schema constructs must work as before.

ii) Physical data independence

 The ability to change the internal schema without having to change the conceptual
schema.  By extension, the external schema should not change as well.

 Physical file reorganisation to improve performance (such as creating access
structures) results in a change to the internal schema.  If the same data as before
remains in the database, the conceptual schema should not change.

 For example, providing an access path to improve retrieval speed of section records
by semester and year, should not require a query to be changed, although it should
become more efficient by utilising the access path.

With a multi-level DBMS, the catalogue must be expanded to include information on
how to map requests and data among the levels.  The DBMS uses additional software
to accomplish the mappings.

Data independence occurs because when the schema is changed at some level, the
schema at the next higher level remains unchanged.  Only the mapping between the
levels is changed.

6.5.5 Database Languages and Interfaces
Because a database supports a number of user groups, as mentioned previously, the
DBMS must have languages and interfaces that support each user group.

DBMS Languages

 DDL – the data definition language, used by the DBA and database designers
to define the conceptual and internal schemas.

 The DBMS has a DDL compiler to process DDL statements in order to identify
the schema constructs, and to store the description in the catalogue.

 In databases where there is a separation between the conceptual and internal
schemas, DDL is used to specify the conceptual schema, and SDL, storage
definition language, is used to specify the internal schema.

 For true three-schema architecture, VDL, view definition language, is used to
specify the user views and their mappings to the conceptual schema.  But in most
DBMSs, the DDL is used to specify both the conceptual schema and the external
schemas.

 Once the schemas are compiled, and the database is populated with data, users
need to manipulate the database.  Manipulations include retrieval, insertion, deletion
and modification.

 The DBMS provides operations using the DML, data manipulation language.

 In most DBMSs, the VDL, DML and the DML are not considered separate
languages, but a comprehensive integrated language for conceptual schema
definition, view definition and data manipulation.  Storage definition is kept separate
to fine-tune the performance, usually done by the DBA staff.

 An example of a comprehensive language: SQL, which represents a VDL, DDL,
DML as well as statements for constraint specification, etc.

Database Management
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DBMS Interfaces

Types of interfaces provided by the DBMS include:

Menu-Based Interfaces for Web Clients or Browsing

 Present users with list of options (menus)

 Lead user through formulation of request

 Query is composed of selection options from menu displayed by system.

Forms-Based Interfaces

 Displays a form to each user.

 User can fill out form to insert new data or fill out only certain entries.

 Designed and programmed for naïve users as interfaces to canned transactions.

Graphical User Interfaces

 Displays a schema to the user in diagram form.  The user can specify a query by
manipulating the diagram.  GUIs use both forms and menus.

Natural Language Interfaces

 Accept requests in written English, or other languages and attempt to understand
them.

 Interface has its own schema, and a dictionary of important words.  Uses the
schema and dictionary to interpret a natural language request.

Interfaces for Parametric Users

 Parametric users have small set of operations they perform.

 Analysts and programmers design and implement a special interface for each class
of naïve users.

 Often a small set of commands included to minimise the number of keystrokes
required. (I.e. function keys)

Interfaces for the DBA

 Systems contain privileged commands only for DBA staff.

 Include commands for creating accounts, setting parameters, authorising accounts,
changing the schema, reorganising the storage structures etc.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

2)    Describe the three levels of data abstraction?

3)    What is Data Independence?

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................
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6.6 DATABASE ENVIRONMENT
The following components form the Database System Environment:

Stored Data Manager

 The database and the database catalogue are stored on disk

 Access to the disk is handled by the Operating System.

 A higher-level stored data manager controls access to DBMS information that is
stored on disk, whether part of the database or the catalogue.

 The stored data manager may use basic OS services for carrying out low-level
data transfer, such as handling buffers.

 Once data is in buffers, the other DBMS modules, as well as other application
programs can process it.

DDL Compiler

A DDL Compiler processes the schema definitions and stores the descriptions (meta-
data) in the catalogue.

Runtime Database Processor

It handles database access at runtime. It receives retrieval or update operations and
carries them out on the database. Its access to the disk goes through the stored data
manager.

Query Compiler

It handles high-level queries entered interactively. It parses, analyses and interprets a
query, then generates calls to the runtime processor for execution.

Precompiler

Precompiler extracts DML commands from an application program written in a host
language. The commands are sent to DML compiler for compilation into code for
database access.  The rest is sent to the host language compiler.

Client Program

This program accesses the DBMS running on a separate computer from the computer
on which the database resides.  It is called the client computer, and the other is the
database server.  In some cases a middle level is called the application server.

Database System Utilities

DBMSs have database utilities that help the DBA manage the system.  Functions include:

 Loading - used to load existing text/sequential files into the database.  Source
format and desired target file are specified to the utility, and the utility reformats the
data to load into a table.

 Backup – creates a backup copy of the database, usually by dumping database
onto tape.  Can be used to restore the database in case of failure. Incremental
backup can be used which records only the changes since the last backup.

 File Reorganisation – reorganise database files into different file organisations
to improve performance.

Database Management
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 Performance Monitoring – monitors database usage and provides statistics to
the DBA.  DBA uses the statistics for decision-making.

Tools, Environment and Communication Facilities

 CASE Tools – used in the design phase to help speed up the development process.

 Data dictionary system – stores catalogue information about schemas and
constraints, as well as design decisions, usage standards, application program
descriptions, user information.  Also called an information repository. Can be
accesses directly by DBA or users when needed.

 Application development environments – (i.e., JBuilder) provide environment
for developing database applications, and include facilities to help in database
design, GUI development, querying and updating and application development.

 Communication software – allow users at remote locations to access the database
through computer terminals, workstations or personal computers.  Connected to
the database through data communications hardware such as phone lines, local
area networks etc.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

4) What is a DML Compiler?

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

6.7 TYPES OF DBMS SYSTEMS
There are several common types of databases; each type of database has its own data
model (how the data is structured). They include; Flat File Model, Hierarchical
Model, Relational Model, Network Model, Object Oriented Relational Model.
These approaches differ in the way in which they permit the user to view and manipulate
relationships. As far as practical implementation is concerned, nowadays, only Relational
and Object Oriented Relational models are the most preferred models by the software
industry.

6.7.1 Flat-file Database
A flat file database is a database designed around a single table. The flat file design puts
all database information in one table, or list, with fields to represent all parameters. A
flat file may contain many fields, often, with duplicate data that are prone to data
corruption. If you decide to merge data between two flat files, you need to copy and
paste relevant information from one file to the other. There is no automation between
flat files. If you have two or more flat files that contain client addresses, for example,
and a client moved, you would have to manually modify the address parameters in each
file that contains that client’s information. Changing information in one file has no bearing
on other files. Flat files offer the functionality to store information, manipulate fields,
print or display formatted information and exchange information with others, through
email and over the Internet. Some flat files may be attached to external files, such as
text editors, to extend functionality and manage related information.
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6.7.2 Hierarchical Database Management System
As its name implies, the Hierarchical Database Model defines hierarchically-arranged
data.

Perhaps the most intuitive way to visualise this type of relationship is by visualising an
upside down tree of data. In this tree, a single table acts as the “root” of the database
from which other tables “branch” out.

You will be instantly familiar with this relationship because that is how all windows-
based directory management systems (like Windows Explorer) work these days.

Relationships in such a system are thought of in terms of children and parents such that
a child may only have one parent but a parent can have multiple children. Parents and
children are tied together by links called “pointers” (perhaps physical addresses inside
the file system). A parent will have a list of pointers to each of their children as shown in
the figure 6.3.

Fig. 6.3: Hierarchical Database Model

This child / parent rule assures that data is systematically accessible. To get to a low-
level table, you start at the root and work your way down through the tree until you
reach your target. Of course, as you might imagine, one problem with this system is that
the user must know how the tree is structured in order to find anything!

The hierarchical model however, is much more efficient than the flat-file model we
discussed earlier because there is not as much need for redundant data. If a change in
the data is necessary, the change might only need to be processed once. Consider the
student flat-file database example as given below:

Table 6.1: Student  flat-file

Name Address Course Grade

Mr. Eric Tachibana 123 Kensigton Chemistry 102 C+

Mr. Eric Tachibana 123 Kensigton Chinese 3 A

Mr. Eric Tachibana 122 Kensigton Data Structures B

Mr. Eric Tachibana 123 Kensigton English 101 A

Ms. Tonya Lippert 88 West 1st St. Psychology 101 A

Mrs. Tonya Ducovney 100 Capitol Ln. Psychology 102 A

Ms. Tonya Lippert 88 West 1st St. Human Cultures A

Ms. Tonya Lippert 88 West 1st St. European Governments A

Database Management
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As we mentioned before, this flat-file database would store an excessive amount of
redundant data. If we implemented this in a hierarchical database model, we would get
much less redundant data. Consider the following hierarchical database scheme:

Fig. 6.4: Hierarchical database Model for Student flat-file

However, as you can imagine, the hierarchical database model has some serious
problems. For one, you cannot add a record to a child table until it has already been
incorporated into the parent table. This might be troublesome if, for example, you wanted
to add a student who had not yet signed up for any courses.

Worse, yet, the hierarchical database model still create repetition of data within the
database. You might imagine that in the database system shown above, there may be a
higher level that includes multiple courses. In this case, there could be redundancy
because students would be enrolled in several courses and thus each “course tree”
would have redundant student information.

Redundancy would occur because hierarchical databases handle one-to-many
relationships well but do not handle many-to-many relationships well. This is because a
child may only have one parent. However, in many cases you will want to have the child
be related to more than one parent. For instance, the relationship between student and
class is a “many-to-many”. Not only can a student take many subjects but a subject
may also be taken by many students. How would you model this relationship simply
and efficiently using a hierarchical database? The answer is that you wouldn’t.

Though this problem can be solved with multiple databases creating logical links between
children, the fix is very kludge and awkward. Faced with these serious problems, the
computer brains of the world got together and came up with the network model.

Disadvantage

Links are unidirectional i.e., parent to child only. The model does not support many to
many relationships. So, in this model if we need any information from lower level then
we have to follow the complete hierarchy of the system.

6.7.3 Network Database Management System
In this many users can access and share one or more databases located on a network.
The network model is the entity relationship model with all relationship restricted to be
either binary or many-one relationships.

The data is represented by collection of records and relationships among data are
represented as links, which can be diagrammatically viewed as pointers. The pointers
are used to locate a particular record.
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Fig. 6.5: A Network Scheme for a Bank Database

Disadvantage

The use of pointers leads to complex structures, which makes mapping of related data
very difficult.

6.7.4 Relational Database Management System
Relational database, on the other hand, incorporates multiple tables with methods for
the tables to work together. The relationships between table data can be collated,
merged and displayed in database forms. Most relational databases offer functionality
to share data:

 Across networks

 Over the Internet

 With laptops and other electronic devices, such as palm pilots

 With other software systems

Designing a relational database takes more planning than flat file databases. With flat
files, you may add information, as you deem necessary. With relational databases, you
must be careful to store data in tables such that the relationships make sense. Building
a relational database is dependant upon your ability to establish a relational model. The
model must fully describe how the data is organised, in terms of data structure, integrity,
querying, manipulation and storage.

Relational databases allow you to define certain record fields, as keys or indexes, to
perform search queries, join table records and establish integrity constraints. Search
queries are faster and more accurate when based on indexed values. Table records can
be easily joined by the indexed values. Integrity constraints can be established to ensure
that table relationships are valid. If you are able to establish a one-to-many relationship
in your data tables, you should be using a relational database because a flat file is not
sufficient to handle your data processing needs.

Relational databases offer more robust reporting with report generators that filter and
display selected fields. Relational databases offer the capability to build your own
reporting modules. Most relational databases also offer the capability to import and
export data from other software. Let us see the terminology that is used in RDBMS:

Relation -> table; Tuple -> Row, Record;

Cardinality -> No. of rows; Attribute -> column, field

Database Management
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Degree -> No. of columns; Primary Key -> unique identifier

Domain -> Set of legal values;

Fig. 6.6: Components of RDBMS

Example: A database file that consists of more than one tables and the relationship can
be created between tables on the common field is called relational database. For example
a database “student” is created having two tables “Address” and “Marks” as shown in
figure below.

Address  
Code 
Name 
City 
Telephone  

Marks  
Code 
Math 
Physics
English 

In the above tables, “Code” is common field in both tables and these two tables are
linked together on this field.

The relational database is very popular and it is mostly used to create and maintain the
large amount of related data. In business, a relational database contains the following
types of tables.

 Table to store customer information

 Table to store employee information

 Table to store order information

 Table to store inventory information etc.

The customer, order and inventory table can be linked together to process or to generate
reports of orders and billing etc.

6.7.5 Object Oriented Relational Database Management
System

Object oriented databases are also called Object Database Management Systems
(ODBMS). Object databases store objects rather than data such as integers, strings or
real numbers. Objects are used in object oriented languages such as Smalltalk, C++,
Java, and others. Objects basically consist of the following:
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 Attributes – Attributes are data which defines the characteristics of an object.
This data may be simple such as integers, strings, and real numbers or it may be a
reference to a complex object.

 Methods – Methods define the behaviour of an object and are what was formally
called procedures or functions.

Therefore objects contain both executable code and data. There are other characteristics
of objects such as whether methods or data can be accessed from outside the object.
We don’t consider this here, to keep the definition simple and to apply it to what an
object database is. One other term worth mentioning is classes. Classes are used in
object oriented programming to define the data and methods the object will contain.
The class is like a template to the object. The class does not itself contain data or
methods but defines the data and methods contained in the object. The class is used to
create (instantiate) the object. Classes may be used in object databases to recreate
parts of the object that may not actually be stored in the database. Methods may not be
stored in the database and may be recreated by using a class.

Comparison to Relational Databases

Relational databases store data in tables that are two dimensional. The tables have
rows and columns. Relational database tables are “normalised” so data is not repeated
more often than necessary. All table columns depend on a primary key (a unique value
in the column) to identify the column. Once the specific column is identified, data from
one or more rows associated with that column may be obtained or changed.

To put objects into relational databases, they must be described in terms of simple
string, integer, or real number data. For instance in the case of an airplane. The wing
may be placed in one table with rows and columns describing its dimensions and
characteristics. The fuselage may be in another table, the propeller in another table,
tires, and so on.

Breaking complex information out into simple data takes time and is labor intensive.
Code must be written to accomplish this task.

Object Persistence

With traditional databases, data manipulated by the application is transient and data in
the database is persisted (Stored on a permanent storage device). In object databases,
the application can manipulate both transient and persisted data.

When to Use Object Databases

Object databases should be used when there is complex data and/or complex data
relationships. This includes a many to many object relationship. Object databases should
not be used when there would be few join tables and there are large volumes of simple
transactional data.

Object databases work well with:

 CAS Applications (CASE-computer aided software engineering, CAD-computer
aided design, CAM-computer aided manufacture)

 Multimedia Applications

 Object projects that change over time.

 Commerce.

Database Management
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Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

5) What is Data Model?

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

6.8 VARIOUS DBMS ARCHITECTURES
DBMS may not be similar for all the applications. Let us discuss various types of
DBMS architectures in this session.

6.8.1 Centralised DBMS Architecture
 Used mainframes to provide main processing for user application programs, user

interface programs and DBMS functionality

 User accessed systems via “dumb” computer terminals that only provided display
capabilities, with no processing capabilities.

 All processing was performed remotely on the computer system, and only display
information was sent to the terminals, connected via a network.

 Dumb terminals were replaces with workstations, which lead to the client/server
architecture.

6.8.2 Client / Server Architecture
 Define specialised servers with specific functionalities (file servers, print servers,

web servers, database servers)

 Many client machines can access resources provided by specialised server.

 Client machines provide user with the appropriate interfaces to utilise servers, as
well as with local processing power to run local applications.

 Some machines are client sites, with client software installed and other machines
are dedicated servers.

 Client – a user machine that provides user interface capabilities and local
processing.

 Server – machine that provides services to client machines such as file access,
printing, and database access.

Two-tier Client / Server Architecture

 In relational DBMSs, user interfaces and application programs were first moved
to the client side.

 SQL provided a standard language, which was a logical dividing point between
client and server.

 Query and transaction functionality remained on server side.  In this architecture,
the server is called a query server, or transaction server.
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 In relational DBMSs, the server is called an SQL server, because most RDBMSs
use SQL.

 In such systems, the user interface and application programs run on the client,
when DMBS access is needed, the program establishes a connection to the DBMS
on the server side.  Once the connection is created, the client can communicate
with the DBMS.

 ODBC (Open Database Connectivity) is a standard that provides and application
processing interface which allows client side programs to call the DBMS as long
as both sides have the required software.  Most database vendors provide ODBC
drivers for their systems.

 Client programs can connect to several RDBMS and send query and transaction
requests using the ODBC API

 Query requests are sent from the client to the server, and the server processes the
request and sends the result to the client.

 A related Java standard is JDBC, which allows Java programs to access the
DBMS through a standard interface.

 These systems are called two tier architectures because the software components
are distributed over two systems, the client and server.

Three-tier Client/Server Architecture for Web Applications

 Many web applications use three-tier architecture, which adds an intermediate
layer between the client and the database server.

 The middle tier is called the application server, or the web serrver.  Plays an
intermediate role, by storing business rules (procedures/constraints) used to access
data from database.

 Can improve database security by checking the client’s credentials before
forwarding request to database server.

 Clients contain GUI interfaces and application specific rules.

 The intermediate server accepts the requests from the client, processes the request
and sends the database commands to the db server, then passes the data from the
database server to the client, where it may be processes further and filtered.

 The three tiers are: user interface, application rules, and data access.

 GUI Web Interface 

Application Programs,  

DBMS 

Fig. 6.7: Three-tier client/server Architecture

Let us study the security features of the database in the next section.

Database Management
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6.9 DATABASE SECURITY
Databases need to have level of security in order to protect the database against both
malicious and accidental threats. A threat is any type of situation that will adversely
affect the database system. Some factors that drive the need for security are as follows:

 Theft and fraud

 Confidentiality

 Integrity

 Privacy

 Database availability

Threats to database security can come from many sources. People are a substantial
source of database threats. Different types of people can pose different threats. Users
can gain unauthorised access through the use of another person’s account. Some users
may act as hackers and/or create viruses to adversely affect the performance of the
system. Programmers can also pose similar threats. The Database Administrator can
also cause problems by not imposing an adequate security policy.

Some threats related to the hardware of the system are as follows:

 Equipment failure

 Deliberate equipment damage (e.g. arson, bombs)

 Accidental / unforeseen equipment damage (e.g. fire, flood)

 Power failure

 Equipment theft

Threats can exist over the communication networks that an organisation uses. Techniques
such as wire tapping, cable disruption (cutting / disconnecting), and electronic interference
can all be used to disrupt services or reveal private information.

Countermeasures

Some countermeasures that can be employed are outlined below:

 Access Controls (can be Discretionary or Mandatory)

 Authorisation (granting legitimate access rights)

 Authentication (determining whether a user is who they claim to be)

 Backup

 Journaling (maintaining a log file - enables easy recovery of changes)

 Encryption (encoding data using an encryption algorithm)

 RAID (Redundant Array of Independent Disks - protects against data loss due to
disk failure)

 Polyinstantiation (data objects that appear to have different values to users with
different access rights / clearance)

 Views (virtual relations which can limit the data viewable by certain users).
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6.10 POPULAR DBMS PACKAGES
There are many popular DBMS available in market, some of them are:

 Borland Paradox

 Filemaker

 IBMDB2

 Informix

 Ingres

 Interbase

 Microsoft SQL Server

 Microsoft Access

 Microsoft FoxPro

 Oracle

 Sybase

 MySQL

 PostgreSQL

 mSQL

 SQL Server

Let us discuss the database project development in the next section.

6.11 DATABASE PROJECT DEVELOPMENT
The conventional Systems Life Cycle consists of:

 Analysis

 Design

 Development

 Implementation

 Maintenance

In practice these phases are not always sharply distinguished; for small projects it may
not be necessary to go formally through every one. The move from one phase to the
next is essentially a move from the general to the specific.

At each stage, particularly where a DBMS is involved, we shall be concerned both
with information and with processes to be performed using that information.

6.11.1 Analysis
The outputs from this stage should be:

A CONCEPTUAL DATA MODEL describing the information which is used within
the organisation but not in computer-related terms. This level of data analysis will be

Database Management
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considered in more detail later. One of the problems with any systems design in a large
organisation is that it must proceed in a piecemeal manner – it is impossible to create a
totally new Global system in one fell swoop, and each sub-system must dovetail with
others which may be at quite a different stage of development. The conceptual data
model provides a context within which more detailed design specifications can be
produced, and should help in maintaining consistency from one application area to
another.

A CONCEPTUAL PROCESS MODEL describing the functions of the organisation
in terms of events (e.g. a purchase, a payment, a booking) and the processes which
must be performed within the organisation to handle them. This may lead to a more
detailed functional specification - describing the organisational requirements which must
be satisfied, but not how they are to be achieved.

6.11.2 Design
This stage should produce:

A LOGICAL DATA MODEL: a description of the data to be stored in the database,
using the conventions prescribed by the particular DBMS to be used. This is sometimes
referred to as a SCHEMA and some DBMSs also give facilities for defining SUB-
SCHEMA or partitions of the overall schema. Logical data models supported by present
day DBMSs will be considered later.

A SYSTEM SPECIFICATION, describing in some detail what the proposed system
should do. This will now refer to COMPUTER PROCESSES, but probably in terms
of INPUT and OUTPUT MESSAGES rather than internal logic, describing, for instance,
the effect of selecting an item from a menu, or any option within a command driven
system. Program modules are defined in terms of the screen displays and/or reports
which they generate. Note that the data referred to here has a temporary existence, in
contrast with what is stored in the database itself.

6.11.3 Development
Specification of the database itself must now come down another level, to decisions
about PHYSICAL DATA STORAGE in particular files on particular devices. For
this a knowledge of the computer operating system, as well as the DBMS, is required.
Conventional program development - coding, testing, debugging etc. may also be done.
If a totally packaged system has been purchased this may not be necessary - it will
simply be a matter of discovering how to use the command and query language already
supplied to store and retrieve data, generate reports and other outputs. Even here an
element of testing and debugging may be involved, since it is unlikely that the new user
of a system will get it exactly right the first time. It is certainly inadvisable for this sort of
experimentation to take place using a live database!

6.11.4 Implementation
This puts the work of the previous three phases into everyday use. It involves such
things as loading the database with live rather than test data, staff training, probably the
introduction of new working practices. It is not unusual to have an old and a new
system running side by side for a while so that some back-up is available if the new
system fails unexpectedly.

6.11.5 Maintenance
Systems once implemented generally require further work done on them as time goes
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by, either to correct original design faults or to accommodate changes in user requirements
or operating constraints. One of the objectives of using a DBMS is to reduce the
impact of such changes - for example the data can be physically re-arranged without
affecting the logic of the programs which use it. Some DBMSs provide utility programs
to re-organise the data when either its physical or logical design must be altered.

6.12 DATABASE ADMINISTRATOR (DBA)
The database administrator (DBA) is the person (or group of people) responsible for
overall control of the database system. The DBA’s responsibilities include the following:

 Deciding the information content of the database, i.e. identifying the entities of
interest to the enterprise and the information to be recorded about those entities.
This is defined by writing the conceptual schema using the DDL.

 Deciding the storage structure and access strategy, i.e. how the data is to be
represented by writing the storage structure definition. The associated internal/
conceptual schema must also be specified using the DDL.

 Liaising with users, i.e. to ensure that the data they require is available and to write
the necessary external schemas and conceptual/external mapping (again using
DDL).

 Defining authorisation checks and validation procedures. Authorisation checks
and validation procedures are extensions to the conceptual schema and can be
specified using the DDL.

 Defining a strategy for backup and recovery. For example periodic dumping of
the database to a backup tape and procedures for reloading the database for
backup. Use of a log file where each log record contains the values for database
items before and after a change and can be used for recovery purposes.

 Monitoring performance and responding to changes in requirements, i.e. changing
details of storage and access thereby organising the system so as to get the
performance that is “best for the enterprise”.

6.13 SUMMARY
A database system is an integrated collection of related files along with the details about
their definition, interpretation, manipulation and maintenance. A DBMS is a major
software component of database system. It consists of collection of interrelated data
and programs to access that data. The primary goal of a DBMS is to provide an
environment which is both convenient and efficient to use in retrieving information from
and storing information into the database.

The DBMS not only makes the integrated collection of reliable and accurate data
available to multiple applications and users but also controls from unauthorised, users
to access the data.

A DBMS is a major software system consisting of a number of elements. It provides
users DDL for defining the external and conceptual view of the data and DML for
manipulating the data stored in the database. The database manager is the component
of DBMS that provide the interface between the user and the file system. The database
administration defines and maintains the three level of the database as well as the mapping
between levels to insulate die higher levels from changes that take place in the lower
levels. The DBA is responsible for implementing measures for ensuring the security,
integrity and recovery of the database.

Database Management
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6.14 ANSWERS TO SELF CHECK EXERCISES
1) DBMS short for Database Management System is a software system that uses a

standard method of cataloging, retrieving, and running queries on data. The DBMS
manages incoming data, organises it, and provides ways for the data to be modified
or extracted by users or other programs. Some DBMS examples include MySQL,
PostgreSQL, Microsoft Access, SQL Server, FileMaker, Oracle, RDBMS,
Clipper, and Foxpro.

2) There are three levels of abstraction:

a. Physical level: The lowest level of abstraction describes how data are stored.

b. Logical level: The next higher level of abstraction, describes what data are
stored in database and what relationship among those data.

c. View level: The highest level of abstraction describes only part of entire
database.

3) Data independence means that the application is independent of the storage
structure and access strategy of data?. In other words, The ability to modify the
schema definition in one level should not affect the schema definition in the next
higher level.

Two types of Data Independence:

Physical Data Independence: Modification in physical level should not affect
the logical level.

Logical Data Independence: Modification in logical level should affect the view
level. Logical Data Independence is more difficult to achieve

4) It translates DML statements in a query language into low-level instruction that the
query evaluation engine can understand.

5) It is a collection of conceptual tools for describing data, data relationships data
semantics and constraints.

6.15 KEYWORDS
Data definition language : The subset of SQL used for defining and
(DDL) examining the structure of a database.

Data manipulation : 1.The subset of SQL used for inserting, deleting,
language (DML)  updating and fetching data in a database.

Data Sub Language (DSL) : A computer language used to define or
manipulate the structure of a relational database
management system (DBMS) 

SQL : SQL is short for Structured Query Language, an
international standard language for manipulating
relational databases.
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7.0 OBJECTIVES
After going through this Unit, you should be able to:
 define a multimedia system and its characteristics;
 discuss the various types of media associated with the multimedia systems;
 differentiate between multimedia and print media;
 describe various storage techniques, access media and formats;
 suggest various s/w and h/w requirements for a Multimedia System; and
 discuss security, copyright and other issues pertaining to the Multimedia Systems.

7.1 INTRODUCTION
With the advent of multimedia, the computer has evolved into a distinctive medium that
is uniquely capable of juxtaposing text, images, audio, and video. Multimedia permits
an extraordinary flexibility in conveying concepts – through words, pictures, and sounds,
as something that can be built or played as well as read or watched. New genres, such
as simulation games, are emerging that challenge the user or player to build some complex
creation – a city, species, business, or world- out of some given set of resources, or
that put the person into a simulated environment or through a scenario to meet a challenge
or learn a skill. The computer thereby turns the passive reader into a participant; it cues
the person of a need to do something, but not necessarily what to do. With multimedia
the computer draws on more of the senses, and more dimensions of intelligence, enlarging
the opportunity to learn for those who have been less able to learn from conventional
teaching materials. Some uses of the new media are genuinely inspired, provocative,
and engaging, and these examples suggest that multimedia have opened an important
new chapter in the history of the imagination.

7.2 MULTIMEDIA
A multimedia system is a system which combines different types of media such as text,
web pages, hyperlinks, audio, video and graphics. The use of multimedia gives the user
a more full experience than a single media such as text. The result of a multimedia
system will include some kind of multimedia presentation.

Multimedia systems are information systems that combine a variety of different media
types, including text, hypertext, audio, images and video. Professional multimedia
systems, especially at the time of creation, involve many participants with a wide breadth
of experience.

The creation of multimedia systems encompasses each of the information processes.

Multimedia primarily focus’ on the information process of displaying, however, it also
investigates a number of the other elements involved, including processing, organising,
storing and retrieving and collecting.

7.3 CHARACTERISTICS OF MULTIMEDIA
SYSTEMS

Multimedia consists of information presented in various forms, including text, numerical,
audio etc.. It will often include some kind of hypermedia. The hypermedia may contain
clickable links or may be disguised as a menu such as at the start of a DVD.

Multimedia is the use of several different media to convey information (text, audio,
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graphics, animation, video, and interactivity). Multimedia also refers to computer data
storage devices, especially those used to store multimedia content.

As the information is presented in various formats, multimedia enhances user experience
and makes it easier and faster to grasp information. Presenting information in various
formats is nothing new, but multimedia generally implies presenting information in various
digital formats. It is also used in visual arts to describe works created using more than
one medium.

Multimedia finds its application in various areas including, but not limited to, art, education,
entertainment, engineering, medicine, mathematics, and scientific research. In education,
multimedia is used to produce computer-based training courses (popularly called CBTs)
and reference books like encyclopaedia and almanacs. A CBT lets the user go through
a series of presentations, text about a particular topic, and associated illustrations in
various information formats.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

1) Define Multimedia and Multimedia Application.

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

7.3.1 Types of Media
The following are the main types of media:

Text refers to any typed material. Text includes numbers and characters whose meaning
must be read to gain meaning. It may be typed in through a word processor but is also
often typed into the multimedia software.

Numbers: Numerals which allow calculations. Includes currency

Hypertext is a term created by Ted Nelson to describe non-linear writing in which you
follow linked paths through a world of textual documents. The most common use of
hypertext is found in the links on World Wide Web pages.

Audio: Sound which has been digitised.

Images (Graphics)

Images are pictures, graphic elements which are displayed on the screen. They maybe
of two types:

Bit-mapped graphics (also known as raster images):  A bit-mapped image is one
composed of pixels. This means that there is a relationship between the graphic on the
screen and the bits in memory. Bit-mapped images can also be called raster images and
would normally be composed in a paint program.

Bitmap images come from paint style programs and are the format used for digital
photos. Bitmap images can be very large but can be compressed down to a small file
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size. Bitmaps pixelate when they are enlarged. Pixelation refers to that block and
grainy look that photos and images get when they are enlarged to much. Jpegs are one
example of raster images.

Vector graphics: These are made of objects such as straight lines, curves or shapes.
It is created through a mathematical formula.

Animation: Animation begins with still images which are then given the illusion of
movement is the movement of a graphic. It is the result of making a sequence of drawing
called frames and showing them rapidly one after another. Animation maybe cel (also
called cell) based or path based

Video: Video combines pictures and sound displayed over time. It is important to
know that here are differences between an animation and a video. An animation begins
with a still images which is then given the illusion of movement but a video records a
continuous event such as a rock concert where movement and sound are of course a
natural part of life; and very much so at a rock concert where a person’s eardrums may
be moving as much as anyone on stage.

Images have proven a very powerful means of communicating messages, and can evoke
a strong response from the user or viewer. However, video, like sound, is very processor
and memory hungry. It also requires special hardware and software to enable it to be
recorded and, to a lesser extent, played back.

Piped/ streamed video is an effective method of displaying video footage on a computer
screen. It involves a suitable video card to receive and translate the video data into a
form that can be displayed on the screen. However, the computer has no control over
the displayed signal.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

2) List the various types of media commonly used with multimedia?

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

7.3.2 H/W Requirements for Multimedia Systems
Multimedia technologies continue to develop, and are thus still in an evolutionary process.
However below is an indication of what you would need to do some basic multimedia.

RAM: 1 GB minimum

SPEED: 1 GHz

STORAGE: Depending on the work your doing you may require anything from a 10GB
available space upwards

The above specifications are only for minimal graphics work. If video editing or heavy
graphics is required than you will need to at least double the minimal RAM and speed

Multimedia
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of the processor. The amount of RAM, ROM and hard drive space that a computer
can utilise is a limiting factor in its multimedia capabilities. This is due to the high storage
requirements demanded by high quality images and sound files.

7.3.3 Components of a Multimedia System
Consider the Components (Hardware and Software) required for a multimedia system:

 Capture devices – Video Camera, Video Recorder, Audio, Microphone,
Keyboards, mouse, graphics tablets, 3D input devices, tactile sensors, VR devices.
Digitising Hardware

 Storage Devices – Hard disks, CD-ROMs, DVD-ROM, etc

 Communication Networks — Local Networks, Intranets, Internet, Multimedia
or other special high speed networks.

 Computer Systems – Multimedia Desktop machines, Workstations, MPEG/
VIDEO/DSP Hardware

 Display Devices – CD-quality speakers, HDTV,SVGA, Hi-Res monitors,
Colour printers etc.

7.3.4 Key Issues for Multimedia Systems
Some of the key issues multimedia systems need to deal are:

 How to represent and store temporal information?

 How to strictly maintain the temporal relationships on play back/retrieval?

 What process are involved in the above Data has to represented digitally –
Analog–Digital Conversion, Sampling etc

 Large Data Requirements – bandwidth, storage, data compression is usually
mandatory.

7.3.5 Desirable Features for a Multimedia System
Given the above challenges the following feature a desirable for a Multimedia System:

 Very High Processing Power – needed to deal with large data processing and
real time delivery of media.

 Multimedia Capable File System – needed to deliver real-time media – e.g.
Video/Audio Streaming.

 Special Hardware/Software needed – e.g. RAID technology.

 Data Representations – File Formats that support multimedia should be easy to
handle yet allow for compression/decompression in real-time.

 Efficient and High I/O – input and output to the file subsystem needs to be
efficient and fast. Need to allow for real-time recording as well as playback of
data.

 for example, Direct to Disk recording systems.

 Special Operating System – to allow access to file system and process data
efficiently and quickly. Need to support direct transfers to disk, real-time scheduling,
and fast interrupt processing, I/O streaming etc.
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 Storage and Memory – large storage units (of the order of hundreds of Tb if not
more) and large memory (several GB or more). Large Caches also required and
high speed buses for efficient management.

 Network Support – Client-server systems common as distributed systems
common.

 Software Tools – user friendly tools needed to handle media, design and develop
applications, deliver media.

7.4 PRINT VS MULTIMEDIA
There are large differences between print and multimedia and advantages and
disadvantages associated with both.

The Mode of Display

Print media is limited to hard copy such as books, newspapers, magazines and posters
while multimedia addresses a number of senses and can be used on computers, mobile
phones, PC/TV combinations and a host of other diverse applications.

The Interactive Nature of Multimedia

Interactivity means that the user is able to make an immediate response to what is
happening and modify the processes. This means that multimedia is more than just a
one way communication. Effectively, there is communication between the user and the
application.

The Dynamic Nature of Multimedia

Once a book is published it cannot change, it is static. An interactive multimedia product
can change depending on actions taken by both the author and the user. The multimedia
author can easily and cheaply change the multimedia presentation whereas this is an
expensive exercise for the traditional author. ‘Smart’ products can change the way they
work based on characteristics the program ‘learns’ about the user.

Data Structure

Computers give us many different ways of accessing data and multimedia systems need
to be structured so the user can easily find the required data. Structures include: A
hierarchical structure or it can be sorted into an order such as alphabetical.

Indexing

We are familiar with the indexes provided in many reference books but these indexes
are always very selective. An interactive multimedia product can index every occurrence
of every word.

Ease of Distribution

Unlike print media which requires printing presses, ink, paper, a willing publisher,
distribution networks in stores, advertising to sell, sales staff to sell the book and a
whole lot of money to cover all of these costs multimedia just requires a computer, a
person to create the material and a distribution media whether that be over the internet,
disc or a combination. Clearly it is much simpler and cheaper to produce most multimedia
then it is to produce books. However it would be simplistic to say that it is always
easier. Movies such as Avatar are multimedia productions which require far more
expenditure than any book and probably far more staff, but this is a particular example.

Multimedia
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Authority of Document

Books are often granted more authority than a website. A website may have very little
checking and editing by a third party whereas most books will have many people who
read through the manuscripts and check sources. However this is not always the case.
There have been many books published which have very doubtful facts and authority. 

7.5 MAJOR AREAS OF MULTIMEDIA USE
Multimedia systems may be designed for a mass audience or for a specific target
audience. Major areas include: education, leisure and entertainment information. It is
possible to combine a number of these areas into one application. Educational games,
or edutainment software, for example, consist of programs that look like games but are
designed to teach in an entertaining manner. Each of the above examples deals with the
presentation of information in a variety of forms. The significant advantage of multimedia
is its interactive nature, which gives control to the participant, rather than the designer.

The variety of presentation methods makes multimedia a useful tool across all the age
groups. Multimedia removes the limitation of forcing everyone to move at the same
pace by providing an interactive approach to learning with more advanced users moving
ahead. Government and businesses also use interactive multimedia programs to train
staff. This type of training is not constrained by time and can be programmed to meet
individual needs.

The main uses of Multimedia are:

 Multimedia In Education and Training

 Leisure and Entertainment

 Information Kiosks

 Virtual Reality and Simulations

Multimedia in Education and Training

The “Reader Rabbit” series is an educational multimedia program which provides
interactive assistance in developing reading skills. Participants include school students,
teachers, parents and siblings. The direct users (students) control activities as they
make choices from a menu.

Data includes text, images and video combined to produce structured activities.

The information technology required is a multimedia computer with a CD-Rom, sufficient
RAM and processing speed.

Leisure and Entertainment

Electronic games, 3D adventure games, sporting games and interactive movies are
extremely popular forms of multimedia applications. The key to their popularity lies in
their interactive nature. The new generations of games provide ingenious levels of
interactivity and realism to captivate the user of the product. The attraction of this type
of application is realism, fast action and user input through peripherals such as mouse,
track-pad, keyboard and joystick. Computer-based games have led to many
developments in interactive computing. This type of application requires a high level of
graphics computing power and hence the impetus to develop more efficient algorithms
for display movement and more powerful graphics cards.
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Information Kiosks

Multimedia has been successfully used to provide guidance through the use of information
centres in locations such as museums, airports, shopping precincts and libraries.

An information centre or kiosk allows the user to search for specific information in his
or her own language without the need to approach a stranger. Location details, product
availability, arrivals and departures, opening and closing times and so on are all examples
of information that can be presented in this format. Touch screens are often an integral
part of an information centre because they reduce the technology literacy requirements
normally associated with the use of computers.

Virtual Reality and Simulations

Virtual reality is a computer-generated artificial reality that projects a person into a
sensation of three dimensional space. Virtual reality is becoming more popular in arcade
type games such as Atlantis. You may have even tried to tee off on a virtual golf driving
range or driven a virtual reality race car. A far more important use of virtual reality is a
simulator. A simulator is a device that represents the behaviour of physical or abstract
systems. Simulators are used very effectively in training applications for aeroplane pilots
or bus drivers to help them deal with various real-life situations in a safe environment.
The medical area has also seen increases in the’ application of simulation technology.
For example, surgeons can rehearse a particular operation on a ‘digital’ patient, and
some phobias, such as a fear of crowds, can be treated. One ethical issue for implementers
of virtual reality equipment is how to keep users from suffering uncomfortable effects
from using virtual reality systems. Known as cyber-sickness or simulator sickness,
symptoms include eyestrain, nausea and confusion and even visual or audio flashback
for some users.

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

3) List some of the applications of Multimedia?

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

7.6 ADVANCES IN TECHNOLOGY
Technological advances have continued to influence the development of multimedia
including: accessibility, communication speeds, compression rates, CDROM, DVD
and firewire technologies. Ease of access to the Internet and World Wide Web has
made it very easy for large numbers of people to access multimedia systems stored as
a series of linked web pages.

The main categories are as follows:

 Storage Capacity

o Hard drives
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o CDROM

o DVD

 Firewire

 Internet Bandwidth

Storage Capacity

Multimedia is very memory hungry but with the explosion in memory storage capacity
this is becoming less and less of an issue. However it is important to note that without
the large increase in storage capacity multimedia would still be difficult to use.

Hard Drives

Hard drive storage capacity continues to explode. Hard drives are now measured in
gigabytes with plans underway for terabyte drives.

CDROM

CD-Rom, which stands for compact disk-read only memory, is an optical disk format
that is used to hold pre-recorded text, graphics and sound. In this type of disk the
content is recorded during manufacture and then read many times by the purchaser.
Initially, a CD-Rom drive was only a single speed drive, with the ability to access data
at 150 kilobytes per second. Through improved technology it is now possible to purchase
drives that are 40 or 60 times (40x, 60x) this speed. The faster the drive spins, the
more quickly it is able to deliver information to the processor. Each CD-Rom disk can
store up to 783 megabytes of information. The development of this technology effectively
began the multimedia revolution due to the sudden availability of high capacity random
access data storage.

DVD

DVD (digital versatile disk) is an optical disk technology that is expected to rapidly
replace the CD-Rom disk (as well as the audio compact disc) over the next few
years. Increased storage means increased flexibility for multimedia developers. A DVD
holds 4.7 gigabyte of information on one of its two sides, or enough for a 133-minute
movie. With two layers on each of its two sides, it can hold up to 17 gigabytes of video,
audio, or other information. Compared to the current CD-Rom disk of the same physical
size, holding 700 megabytes, this is more than 28 times as much information!

Firewire

FireWire is essentially a new way to connect different pieces of equipment, such as
digital videos and hard drives, so they can share information rapidly and easily. Originally
created by Apple, and standardised in 1995 as the specification IEEE-1394, it is a
technology that:

 allows fast transfer of data (up to 400 Mbps);

 allows many devices to be connected simultaneously on the bus network;

 is hot pluggable;

 provides power through the cable;

 allows plug and play;

 has low cabling costs;
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 has increased data transfer rates through the use of a fairly inexpensive option.;

 This has expanded the possible applications of multimedia into more powerful and
data intensive areas.

Internet Bandwidth

Improvement in communication speed (or bandwidth) through technologies such as
cable, ADSL and satellite have made the presentation of multimedia content via the
Internet a viable option increasing download speeds that used to frustrate many Internet
users, particularly for pages that incorporate graphics, sound and video. Compression
and animation technologies such as MP3, QuickTime, Flash, Shockwave, Java and
JavaScript enhance the interactive nature of the World Wide Web.

7.7 MULTIMEDIA DESIGN
It is important when designing multimedia that all elements be in harmony and that
images and graphics be optimised for fast and efficient use of bandwidth.

There are 3 aspects to optimisation:

 the basic coding of the page,

 scripts that are used on the page,

 images (large can have the most significant impact on load times).

Image Types

There are many image formats in use on web sites but the three most common are GIF,
JPEG, and Flash content. Our focus is on GIF and JPEG.

The gif format only uses 8-bit colour (256 colours) but it is a ‘lossless’ format and so
detail is not reduced. Gif images are the best way to render artwork such as line drawings,
charts and maps, particularly if the number of colours can be reduced. However GIFs
will give a larger file size if the picture has too many colours. For an image with a large
number of colours a jpeg is preferable.

Jpeg images use 24-bit colour (16,777,216 colours) but the compression algorithm is
loss. This means that resolution on a computer screen is lost on compression, this may
not be noticeable but a hardcopy image would show the degradation. Jpeg images are
used for photographs (screen but not good printed). A reasonable quality photo in jpeg
is commonly around 20-30 Kb where the equivalent in gif could be 100-300 Kb. With
jpeg files the quality required is set when the image is saved.

Each image format has strengths and weaknesses. GIF or Graphics Interchange Format
was developed by CompuServe before the Internet days as a way to share images on
the CompuServe bulletin boards. Due to limitations with screen resolutions and colour
depths at the time, GIF images were only able to show 256 colours, more colours were
imitated by Dithering, a process of tricking the eye into seeing one colour by using 2 or
more sets of colour dots spaced closely together.

A chessboard with black and white squares becomes a grey blob when viewed from a
distance even though close up we can see each black or white square. This is the
concept behind dithering. Our eyes merge the black and white squares together. On a
computer screen these black and white squares would be called pixels awhile the number
of black and white squares would be called the resolution. The more squares the better
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the definition of the image. Unfortunately if there are too many colours to be dithered
the file size becomes very large.

The JPEG file format is newer and can handle up to 16 million colours. The initial
problem is that JPEG images do contain many more colours, and each colour requires
coding for display, possibly making larger file sizes. The compression rate of a JPEG is
easily changed at the time it is saved. It is possible to get a good balance between
resolution and compression rate. Lower compression rates will still give a quality print.
As the compression rate increases the image on the screen will not seem to vary much
but the print quality will degrade quickly as the compression rate is increased.

Improving Load Times

The main way to make an image load faster is to make the file size smaller. This can be
accomplished by either:

 making the dimensions of the image smaller, or

 decrease the amount of coding that is required to display the image.

The easiest way to reduce an image’s file size is to reduce the image’s physical dimensions.
Make the picture smaller. Smaller the image, smaller is the file size.  If we reduce the
image size by one half to 40 pixels by 40 pixels we then have 40x40 or 1600 pixels. So
reducing the image size in half reduces the file size to one fourth of the original. The
following are the principles to be followed for the Image file size reduction:

 Use the smallest image dimensions that will work with your layout. And likewise
the fewer images on the page, the fewer image pixels, therefore the smaller the
page size. GIF and JPEG image formats use different methods of saving image
information and so tend to be better at showing some types of images and worse
at showing others. GIF images, since they are limited to 256 colours per image,
are better at displaying images with large solid blocks of colour and images with
very small physical dimensions. The images look flatter and don’t have the depth
of colour of a JPEG. The GIF format will produce smaller file sizes than JPEG for
these types of images.JPEG images are better at showing gradients or subtle changes
from one colour to another. Therefore JPEGs reproduce photographs very well,
or any other image with gradations.  This means that the JPEG format will produce
smaller file sizes for photo style images than the GIF format will.

 Choose the correct image format for the type of image you are using. Most web
pages will contain a combination of GIF and JPEG images. Decreasing the coding
is called image compression. Both GIF and JPEG images can be compressed but
the process is different. In GIF images we try to limit the number of colours, in a
JPEG image we use software algorithms to remove redundant information from
the file. Whenever we compress a file we will loose some image quality. We have
to reach a balance between a small file size and acceptable image quality.

 Find the least acceptable level of image quality. Most images can handle some
compression with very little quality loss, and all images can stand more image
quality loss and still be acceptable.  You need to be able to decide how much
decline in image quality is acceptable, but remember the lower the quality the fast
the image load. GIF images can usually be reduced from 256 colours to 128
colours or less, the fewer colours used the smaller the file size. JPEG images can
almost always be reduced to a quality setting of 80% and frequently can be reduced
down to as little as 15-30%. So when you use a higher compression level (smaller
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number) the file size will be reduced.  Try smaller and smaller settings until you find
the smallest setting that still displays an acceptable quality. The fastest loading
page will have no images and the slowest loading page will be completely filled
with high resolution images.

Hardware in Multimedia Systems

A variety of hardware is required to create and display the multimedia applications that
are currently available including:

 Display Devices

o Cathode Ray Tubes

o Flat Panel

§ Touch Screens

§ Liquid Crystal Display (LCD) Screens

 Projection Devices

 Speakers and sound

 MIDI 

Display Devices

Display devices, also called screens, monitors or CRTs, are output devices 

Display screens are of two types:

Cathode-ray tubes (CRTs) produce an image by firing a beam of electrons onto the
inside of a phosphorous coated glass screen.

Flat panel displays are made up of two plates of glass with a substance in between
them that can be activated in different ways. Flat panel displays are distinguishable by
either the substance between the plates (liquid crystal, electroluminescent material or
gas plasma) or the arrangement of the transistors in the screen that control each pixel.

Touch Screens

A touch screen is sensitive to human touch. Used at information kiosks, computer
based training, and by those having difficulty manipulating a mouse or keyboard. 3
types are: resistive, surface wave and capacitive.

Resistive: Coated with thin, metallic, electrically conductive and resistive layer. When
touched a change in electrical current is registered as a touch event and sent to controller
for processing.

Surface wave: Uses ultrasonic waves that pass over the screen. When touched, a
portion of the wave is absorbed. This change in the ultrasonic waves registers the
position of the touch event and is sent to controller for processing.

Capacitive: Coated with material that stores electrical charges. When touched, a small
charge is drawn to point of contact. Circuits located at each corner of panel measure
charge and send the information to the controller for processing. Capacitive touch screens
must be touched with a finger.
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Liquid Crystal Display (LCD) Screens

An LCD screen is an electro-optical device commonly used in digital watches,
calculators, and portable computers.

 The LCD is a liquid crystal placed between a pair of transparent electrodes. Liquid
crystal changes the phase of the light passing through it and can be controlled by
voltage applied between electrodes. When placed between a pair of plane polariser
plates then light can pass through only if the correct voltage is applied.

 LCDs are formed by integrating a number of such cells or by using a single liquid
crystal plate and a pattern of electrodes. Electrodes in computer screens are in
rows and columns. By applying voltage to a row and several columns the pixels at
intersections are set.

 Putting a transistor, on top of each pixel, can slow fading. It will also ‘remember’
the setting of that pixel. These active matrix displays are as good as CRTs but
much more expensive than passive matrix displays. 

Projection Devices

A data projector is a device that allows the projection of video and graphic images onto
a screen. Typically, projected images were best viewed in reduced light but the newer
models are much brighter (1,000 lumens or more) and this has become unnecessary.

Three main types of technology are used to project images:

 Three guns: Separate guns for each of the red, blue and green colours are used
to project light onto a screen. Although they produce the most light output they are
also the most expensive.

 Digital light projector (DLP) technology uses a tiny multi-faceted semiconductor
mirror chip to reflect light from a light source. The chip controls tiny semiconductor-
based mirrors to produce an image that is sharper than the traditional LCD version.

 LCD-based projectors perform in a similar way to LCD screens where the light
source is passed through an LCD before being projected onto a screen.

Speakers and Sound

Audio output is relatively straightforward - you just connect speakers or headphones
to the sound card of the computer.

 Sound output devices are designed to convert binary data into information by
producing digitised sound.

 To do this you need the necessary software driver and sound card and a digital
audio circuit board such as a Sound Blaster.

 Sound cards generally plug into an expansion slot on the motherboard or come
integrated with the mother-board on newer machines.

 Speakers provide the easiest and cheapest output device though it is often the
quality of the sound file rather than the speakers that contribute most to the quality
of the sound.

MIDI

MIDI, or musical instrument digital interface, is used to input or output analog musical
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information from electronic musical instruments (known as synthesizers) in digital format
ready for use by a computer. The information transmitted contains the note identification,
time of play and the loudness, rather than the actual note itself. Midi files are very
small compared to wav files. 

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

4) State whether the following statements are true or false.

a) A computer capable of handling text, graphics, audio, animation and video is
called multimedia computer.

b) MIDI data is digitised sound.

c) Animation can be used to emphasise the three-dimensional nature of objects.

d) Most commonly used format for graphics is .BMP or bitmap pictures.

e) If the sequence and timing of these multimedia elements can be controlled by
the user, then one can name it as Non-Interactive Multimedia.

7.8 SOFTWARE IN MULTIMEDIA SYSTEMS
There is a range of software used for creating a multimedia product. The popular among
them are:

 Presentation Documentation

 Multimedia Application Software

 Authoring software

 Animation software

 Web browsers and Editors

7.8.1 Presentation Documentation
Computer-generated presentations are quickly replacing the more traditional paper
and slide-based approach. Presentation software uses graphics and data/ information
from other software tools to communicate and make presentations of data to others.
Modern presentation software packages provide facilities to create presentations that
may be viewed using: a standard monitor, a data projector for a large group, hard
copies of slides and transparencies hard copies of paper handouts. This type of software,
including packages such as Microsoft PowerPoint and Claris AppleWorks, can
incorporate text, numbers, images, audio, animation and video, and allow relatively fast
generation of a series of linked screens.

Presentation software creates several different types of documentation to help the
presenter. These include:

On Screen Presentations

These are a series of slides which take the place of slide projectors as well as overhead
projectors. They can be displayed on a monitor or projected onto a screen by way of

Multimedia



Middleware Technologies

8 6

a data projector. The timing of the slides can be either manual from the click of a mouse
or other peripheral or automatically timed.

Overhead Transparencies

The slides can be printed out onto overhead transparencies if required.

7.8.2 Multimedia Application Software
Application software is a computer program used for a specific task. Programs such as
Microsoft Word, used to produce word processed documents, and Adobe Photoshop,
used to generate complicated graphical images, can be used to generate content that
can be incorporated into a multimedia project. A wide variety of specific software is
available to generate and edit the various parts of a multimedia project such as video,
sound grabs, images and animation. Some word processing software even allows the
direct importation of video or sound.

7.8.3 Authoring Software
Multimedia authoring packages are designed to be relatively quick to use. These types
of multimedia tools are called rapid application development tools or RAD tools.
Authoring software allows the user to sequence and time the occurrence of events,
determining which graphics, sound, text and video files are to be utilised at any given
point in the final product. The software also allows the creator to determine the level of
user interaction. Examples of this type of software include eXe, Courselab, Xerte,
Macromedia Authorware, Macromedia Director etc. Authoring software is going to
play an ever increasing role in education and training as employers and politicians
increasingly look for low cost and more flexible solutions to their training needs.

7.8.4 Animation Software
There are many programs designed to create animations and to ease the burden of
drawing the hundreds of cells or frames required for even a simple animation. Each has
its own strengths and weaknesses but the majority provides the tools to produce an
animation using one of the different animation techniques, including the traditional frame-
by-frame, path-based, morphing or warping. Examples of animation software are
Blender, Flash, Director, Image soft, 3D Max. There are countless others. However
simple animations can be made simply and easily by using a GIF animator.

7.8.5 Web Browsers and Web Editors
Web browsers are used to look for information on the net while editors are used to
create web pages. There are many web browsers but the most common two are
Microsoft Internet Explorer and Netscape Navigator. Editors are used to create web
pages and they range from text based such as Note pad and BBedit to WYSIWYG
systems such as Dreamweaver and Frontpage. Pages on the WWW are written primarily
in html (Hypertext Mark-up Language).

HTML files are plain text files and describe text formatting and are not a programming
language as such, All html documents have the same structure with different codes, as
the designer requires. Software that is WYSIWYG - what you see is what you get -
implies that the contents of the screen are the same as the final printer or browser
versions.



8 7

Self-Check Exercise

Note: i) Write your answers in the space given below.

ii) Check your answers with the answers given at the end of this Unit.

5) What is the basic H/W and S/W required for creating a simple Multimedia
Presentation?

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

.....................................................................................................................

7.9 INFORMATION COLLECTION IN MULTIMEDIA
SYSTEMS

Collecting information for a multimedia project generally requires the digitisation of
data presented in another form and will include a range of activities including: writing
the notes, digitising audio and video, editing and generally gathering information.

Digitisation of Analog Data

Audio, video and images are often represented in an analog format. To be used in a
multimedia presentation they must first be converted to digital. An ADC or analog to
digital converter is the tool used in this process.

Digital Text and Numbers

For use in a computer, data needs to be converted into binary numbers. This has been
achieved for letters, numbers and other characters by the development of a number of
coding methods. One common coding system is known as ASCII, which stands for
American Standard Code for Information Interchange. ASCII is a 7-bit code that
represents 128 letters, numbers and punctuation symbols as a 7-bit binary number. The
eighth bit in the byte is used as an error checking parity bit. For example, the letter ‘e’
is converted to the binary number 1100101 using the ASCII code, which can be stored
by the computer. Other coding systems exist which also translate characters into the
digital equivalent. EBCDIC or Extended Binary Coded Decimal Interchange Code is
used by IBM mainframes. This system uses an 8-bit code, and allows 256 different
symbols.

Digitisation of Graphics

Digitisation of graphics refers to the process of putting images into a format that computers
can read and store.

Bit mapping, or memory mapping, is the relation-ship between the image on screen and
the bits stored in primary and/or secondary memory. One or more bits must be stored
for each pixel (picture element) drawn in an image.

Each dot on the screen is known as a picture element or pixel. The more pixels that can
be displayed by a screen, the better will be the image quality or resolution.

Pixel: At the simplest level, 1 pixel is represented by 1 bit, where 1 means on, or black,
and 0 means off, or white. For example, a black and white graphic 640 by 400 would
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contain 256,000 (640 x 400) pixels, and would require 256,000 bits to be stored in
memory. That is, 32,000 (256,000 = 8) bytes of memory or 32.25 (32,000 =1,024)
Kb.

Resolution is normally quoted in terms of the number of horizontal pixels times the
number of vertical pixels, for example, 800 times 600.

Tones (colours or greyscale) are a progressive series of shades from white to black,
and are used in graphics to add contrast and detail. Such an image however, requires
more memory because each pixel must be described by an increased number of bits.
For example, 2 bits of memory per pixel (00, 01, 10, 11) would produce 4 (2s) tonal
colours, 3 bits per pixel would allow 8 (23) tones (000, 001, 010, 011,100, 101, 110,
111) and so on.

The term Bit Depth refers to the number of bits that describe each pixel in the image.
A 16-bit image would produce 65,536 (216) different colours or tones. It is obvious
that the more detailed the image, in colour and tonality, the more memory would be
required for its storage.

Digitisation of Audio

Sound and other analog data is generally represented as a transverse wave, and can be
converted to digital form by a process called sampling. The two important aspects of
sampling are sampling size and sampling rate.

Sampling size refers to the number of bits used to store each sample from the analog
wave. For example, an 8-bit sample can represent 256 (28 = 256) possible levels in a
particular sample.

A higher sample size will result in increased accuracy, but higher data storage
requirements.

Sampling Rate refers to the number of samples or slices taken of the analog wave in
1 second. The higher the sampling size, the better will be the representation of the initial
analog signal.

Methods of Digitising/ Capturing Video Images

Capturing full motion video requires a video capture card to digitise the signal (unless
using a digital video recorder, in which case it is already digitised) before storing on disk
for later editing.

The standard PAL (phase alternate line) video signal used in India displays a frame rate
of 25 frames per second. One frame of medium resolution and 16-bit colour requires
approximately 1 Mb of storage space per frame. This translates to 25 Mb per second
of video, or a staggering 1,500 Mb per minute.

Current personal computers cannot sustain a transfer rate between secondary and
primary storage of 1,500 Mb per minute, so a number of solutions are applied including:

 Video data will be compressed during recording, using a codec.

 Decreased colour depth to fewer colours or even black and white shades requires
significantly less memory.

 Decreased resolution reduces number of pixels to describe in each frame.
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7.10 STORYBOARD FOR MULTIMEDIA SYSTEMS
A storyboard is an illustrated scene-by-scene layout of the multimedia presentation. It
generally includes text notes and sketches of the most important parts of the presentation.
The components of any multimedia production, be they text, hypertext, sound, video or
graphics, have to be combined in such a way that the result is a blended product in
which each element supports all others.
Different types of storyboards, as listed below, help achieve this:
Linear – sequential, movement through project.

Fig.7.1: Linear Sequential Storyboard Format

Hierarchical – top down approach, which provides users with multiple choices at
each stage of the project.

Fig. 7.2: Hierarchical – Top Down Approach Storyboard Format
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Non-linear – the user can choose the path of navigation through the project without
significant restriction. There is no particular structure inherent in the design.

Fig.7.3: Non Linear Storyboard Format

Composite - aspects of each of the previous three types are incorporated.

Fig. 7.4: Composite Storyboard Format

7.11 PROCESSING IN MULTIMEDIA SYSTEMS
Processing involves the modification of data in some way that makes it more useable.
Processing in a multimedia system will include editing and compression. Some examples
of processing include:
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 Image processing (morphing, Warping)

 Animation Processing (Cell-based animation, Path-based animation)

Multimedia consists of information presented in various forms, including text, numerical,
audio and so the creation of this material occurs in an integrated environment using,
items from different sources, such as sound and video.

The integration of a range of forms of information leads to increased storage requirements.
For example, a two hour movie contains so much sound and visual information that if
stored without modification on a standard CD-Rom it would require over 300 disk
changes during a single showing.

The solution to the storage dilemma comes from a mathematical process called
compression. Compression is a method of removing redundant or repetitive elements
from a file so that the file requires less storage space and thus less time to transmit. The
algorithm that defines the process of compression and decompression is called a codec.

A concept that is often utilised in multimedia is called hypermedia. Hypermedia refers
to the linking of data types. For example, clicking on a particular section of the screen
may cause additional text to be displayed, or the user to ‘jump’ to a different section of
the program. The term ‘hyper’ refers to a link between elements of the program, and so
hypertext, for example, is text that is linked to other sections.

7.11.1 Image Processing
Image processing is another aspect of video work that demands processing power.
There are two primary types that you need to be aware of:

Morphing is an image processing technique used for metamorphosis from one image
to another. The idea is to get a sequence of intermediate images which when put together
with the original images would represent the change from one image to the other. For
example, changing a photo of yours into any another photo say, a tiger.

Warping refers to modification made to an existing image by stretching and resizing. In
this case it is clear that you are still looking at the original image. For example, changing
a picture of yours so that you have very large ears.

7.11.2 Animation Processing
Animation processing is required when presenting a series of graphics in rapid succession.
The human eye experiences something called persistence of vision, and this is the principle
upon which animation is based.

As one graphics frame is replaced by the next the screen is blank for approximately
500 milliseconds. However, the eye retains the last image until it is replaced and thus
we see movement.

While all animation involves a series of images, there are several techniques that may be
used:

Cel-based animation is a method of producing animation by the creation of a sequence
of individual still images each produced on a separate cel. The term “cel” refers to an
individual still image to be used in the animation sequence and comes from the more
traditional hand-drawn images on separate sheets of celluloid, hence “cel”.

Path-based Animation is a method in which the starting point, end point and the path
to be followed by an object are defined. The software generates the object, as it moves
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along the defined path, to represent the animation. Path-based animation involves
displaying the movement of objects onto a fixed background.

The background pixels do not change, only those for the moving object. This saves
memory and processing time. Animation is achieved by drawing the object, wiping it
and the drawing the object in a new position. This process is made easier because
animation software can create objects between two objects in key position.

7.12 STORING AND RETRIEVING IN
MULTIMEDIA SYSTEMS

The concept of storage and retrieval is very important for any multimedia project because
whether the mode is text, video, audio or graphic there are a wide variety of formats
available. Each format will have advantages and disadvantages.

Not all formats will be supported by any program so that means that you must find a
suitable format from the list of supported formats. Also not just any format will do the
job. you must chose the right format for the right job. For example jpegs are a compressed
graphic format. They have great colours but cannot be altered without losing data. If
image needs to be altered then a different format should be used.

The different modes and their formats are as follows:

Video: avi, mpeg, quicktime, real. The same as with other file types there are a large
number of video formats. The main ones are avi, mpeg, quick time, real player, flash
and shockwave. mpegs are quickly becoming a standard. Mpegs are used on VCD
(mpeg 1) and DVDs (mpeg 3 which is a higher resolution than mpeg 1).

 AVI (Audio Video Interleave)

 MPEG (Motion Pictures Expert Group)

 Quicktime Apple digital video, also available on PC

Image: jpg, eps, pict, tiff, bmp, gif: When choosing an image type two criteria are
important: accessibility and file size. Below are formats: 

 JPG (Joint Photographics Experts Group) A lossy compression format designed
to reduce the size of full colour bit maps.

 EPS (Encapsulated Postscript) Uses vector graphics and often will only be
interpreted by a printer. Therefore it cannot be displayed on screen.

 PICT Apple graphics format that is bit mapped or vector.

 TIFF (Tagged Image File Format) A bit mapped format, standard choice for
scanned images.

 BMP (Bit Map) An uncompressed bit mapped format (Native to PCs).

 GIF (Graphics Interchange Format) Bit mapped format that uses a lossless
compression algorithm. Limit of 256 colours.

Text and numbers: txt, doc, pdf, html, rtf: There are not a large number of text
formats. Below are the main ones:

 TXT ASCII text (only ASCII characters) or delimited text exported from a database

 DOC Microsoft Word file
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 PDF (Portable Document Format) Proprietary digital format produced by Adobe
which preserves format and look of text document.

 HTML - (Hypertext Mark-up Language) Text based language which a web
browser uses to render text, images, audio and video.

 RTF (Rich Text Format) Used to produce a document that can be read by other
word processors.

Audio: Wav, midi, mp3. There are a wide range of audio formats. Below are
three common ones.

Wav (wave file): digitised audio file of varying levels of quality which can be played
directly by a sound card. This is a native PC sound file.

MIDI: (musical instrument digital interface) stores note information rather than sound
which results in a small in a field size. However, it requires a synthesizer to replay.

MP3: Derived from audio layer 3 in a MPEG video. Currently requires a software
player.

Compression and Decompression

These days compression of data is not only handy but is crucial to multimedia
performance. In the following pages we are going to examine the various aspects of
compression and decompression. Some of the important terms for this work are the
following: compression, decompression, sip, archive, tar, mpeg, video compression,
image compression, lossless, lossy, decompression, codec, coding redundancy, spatial
redundancy, temporal redundancy, psycho visual redundancy.

Video Compression

Video compression is achieved by the use of a codec. A codec is a compression/
decompression algorithm. A number of video codecs are in use, including Indeo (created
by Intel) and MPEG-1, 2, 3, 4 and 7, created by the Moving Pictures Expert Group.

Image Compression

Image compression involves minimising the size of a file without degrading the quality of
the image to an unacceptable level. The reduction in file size allows more information to
be stored in a given amount of disk or memory space. Smaller file size also reduces the
time required for information to be sent over the Internet. Compression schemes can
be:

Lossless, where the decompressed data is identical to the original data with nothing
lost in the translation, or,

Lossy, where the decompressed data is slightly different from the original, hopefully in
insignificant ways, though some data is sacrificed for the sake of compression.

Decompression

Decompression (expansion of a compressed file) is only possible if lossless compression
has been utilised. It is only possible to expand a compressed file format to the original
data set if the compression algorithm does not discard information in the original
compression process. Compression strategies can take advantage of four kinds of
redundancy:
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 Coding redundancy, which relies on the fact that not all data will occur with the
same probability.

 Spatial redundancy, which occurs because pixels that are near each other are
likely to be similar to each other.

 Temporal redundancy, which occurs because pixels in consecutive frames of a
video are likely to be similar, for example a “talking head”.

 Psycho visual redundancy, which occurs because the human visual system is better
at detecting changes in luminance (brightness) than chrominance (colour).

Image Format Choice

Web graphics are very different to printed graphics. They must have a small file size and
may be interactive. Web graphics require to use RGB (red green blue) colour scheme
designed for monitors while a print media requires CMYK. Common web formats are:

 GIF

 JPEG (also called jpg)

 PNG

Images in other formats can be very large and need to optimise for the web and changed
into one of these formats.

As such it is important to consider the most appropriate compression technique to utilise
when preparing an image for the World Wide Web or any other multimedia project.
Consider the criteria like:

 The gif format only uses 8-bit colour (256 colours) but it’s a ‘lossless’ format and
thus detail is not reduced. Gif images are the best way to render artwork such as
line drawings, charts and maps, particularly if the number of colours can be reduced.
However GIFs will give a larger file size if the picture has too many colours. For
an image with a large number of colours a jpeg is preferable.

 Jpeg images use 24-bit colour (16,777,216 colours) but the compression algorithm
is lossy. This means that resolution on a computer screen is lost on compression,
this may not be noticeable but a hardcopy image would show the degradation.
Jpeg images are used for photographs (screen but not good printed). A reasonable
quality photo in jpeg is commonly around 20-30 Kb where the equivalent in gif
could be 100-300 Kb. With jpeg files the quality required is set when the image is
saved.

7.13 ISSUES RELATED TO MULTIMEDIA
SYSTEMS

There are many issues that have arisen from the development of multimedia. Some of
them are to do with the violent nature of some content and the appropriate use of the
internet but many of the issues stem from other areas such as copyright, the way
technology has moved ahead so quickly and the general impact of those issues upon
the individual and society. Lastly individual rights must also be protected along with
those of companies and this is covered by concerns over data integrity (how accurate
is the data that we are being fed. Is it accurate? Is it honest? Has there been a corruption
of the data in any way.
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The following are the important issues to be considered while developing the Multimedia
Systems:

 Copyright

 Appropriate Use of The Internet

 Merging Technologies

 Data Integrity

7.13.1 Copyright and Multimedia Systems
Under the Copyright Act it is illegal to reproduce a literary work or to make an adaptation
of that work without the permission of the author. “Literary work” includes software:

 The author or producer has the right to expect payment for their work. Time and
effort are worth money.

 Computer programs are a particular problem because they are relatively easy to
copy and modify. This becomes an ethical issue for users who have the technology
to break copyright and avoid detection.

 If a multimedia developer does not acknowledge where images and sound files
come from then they are breaking copyright.

 Shareware allows a user to try the software before buying. But shareware is not
freeware and if you continue to use the software after the allowable trial period is
over then you are breaking copyright.

Software licensing

There are a number of different license formats as listed below:

Single user - the price allows the use of one copy of the software on one computer.

Site license - the price allows the use of the software on a specified number of
computers.

Freeware - software may be used freely and copied for other users

Shareware - software may be trailed for a period of time before a licensing fee is paid
for a single or site license.

7.13.2 Appropriate Use of the Internet and Multimedia
Systems

Appropriate levels of usage of Internet and other content involve the concepts of ethics
and moral behaviour. Ethical issues relate to questions of morals. Is it right or wrong to
proceed with a specific action? If you behave ethically or morally then you are behaving
in a manner that most people would regard as the right way to act. Correct ethical or
moral behaviour would normally reflect the norms of society. It is important to understand
that norms change. Many people may feel that what was considered unethical behaviour
30 years ago is normal in current times. Widespread access to the Internet keeps the
issue of ethical and moral issues active. People are being exposed to all sorts of material.
Who should have access to different material? How much censorship should be imposed
on the Internet? How much censorship is possible?
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7.13.3 Merging Technologies and Multimedia Systems
The lines dividing computers, telephones, radio, television, voice and data are blurring.
This merging of content is called “digital convergence” which is where content can be
stored as a digital file rather than the more traditional analog form:

 It is possible to use the Internet for telephony using a PC with a sound card,
microphone and a standard Internet connection.

 Desktop radio broadcasting is also available on the Internet. Sites such as Real
Audio’s www.real.com provide a compressed sound source that can be
downloaded and played in real-time. Television has also made it to the Internet
with WebTV. However, bandwidth limitations produce a poor quality picture.

 Audio and video files are available in two forms, downloadable files or live content
called streaming audio or video. Streaming audio or video allows you to listen to
or view the sound/ video while it is being downloaded.

7.14 DATA INTEGRITY IN MULTIMEDIA SYSTEMS
Data integrity means that the data is accurate, consistent, and up-to-date. As the amount
of information available on the Internet increases, the issue of data integrity becomes
more important. Multimedia systems used by educational institutions must use a data
source that has integrity.

The reliability of material is not always easy to establish. There are many unreliable
sources of information on the web. It is important that only reliable sources be quoted
and used for research.

The publishers of the Encyclopedia Britannica could choose to use data from questionable
sources but do not, instead preferring to spend the necessary time on research to ensure
the integrity of their product.

It is important that those researching material on the web ensure that all source data is
cross-referenced to ensure its accuracy.

7.15 CAREER PATH IN MULTIMEDIA
Business: Multimedia designers can be used in business application in a variety of
ways like presentations, training, marketing, advertising, product demos, databases,
catalogues and networked communications. They can be successfully engaged in video
conferencing also.

Advertising: Imaginative and attractive advertisements can be made with the
combination of text, pictures, audio and video. Multimedia designers have a big role in
creation of advertisements. A product is well received by a customer if it is supported
by a good multimedia advertisement campaign.

Gaming and Graphic Design: They are perhaps making the maximum use of
multimedia. No computer game is complete without elaborate computer graphics, be it
a arcade game, strategy based game or sports game. A computer game with good
graphics is more enticing to play then a game with less or bad graphics. Multimedia
designers have a great role in making a game successful.

Product Design: Multimedia can be used effectively for designing a product. First its
prototype can be made before actually making the product. Multimedia programmers
can be employed in this work.



9 7

Education and Training: It is perhaps the need of the hour requirement for the
multimedia. Topics which are difficult to understand by reading the text can be made
simple with the help of multimedia. Time is coming when the multimedia lessons will
take place of classroom teaching. Students can repeat a lesson as many times until he
understands the concept. Multimedia designers have big role in all this work.

Leisure: Multimedia can also be used for entertainment. Most of the cartoon films are
made with the help of multimedia. It is used in scientific movies to give special effects
like animation, morphing etc. Actors created by combining different frames with the
help of multimedia can replace the actual actors.

With this Multimedia, students will gain creative skills and technological knowledge
leading to many exciting career opportunities including in the fields of electronic publishing,
web design, information architecture, human-computer interface, design, multimedia
design and production, 3-D animation, computer games, exhibition design, scientific
and medical visualisation and special effects for film and television. Escalating demand
for these skills by the Creative Industries provide students with exciting options for
professional placement and eventual employment nationally and internationally.

7.16 SUMMARY
Multimedia is the media that uses multiple forms of information content and information
processing (e.g. text, audio, graphics, animation, video, interactivity) to inform or
entertain the user. Multimedia also refers to the use of electronic media to store and
experience multimedia content. Multimedia is similar to traditional mixed media in fine
art, but with a broader scope. The term “rich media” is synonymous for interactive
multimedia.

Multimedia may be broadly divided into linear and non-linear categories. Linear active
content progresses without any navigation control for the viewer such as a cinema
presentation. Non-linear content offers user interactivity to control progress as used
with a computer game or used in self-paced computer based training. Non-linear content
is also known as hypermedia content.

Audio is an important component of multimedia which can be used to provide liveliness
to a multimedia presentation. MIDI is Musical Instrument Digital Interface. MIDI is a
communication standard developed for electronic musical instruments and computers.
A digital image is represented by a matrix of numeric values each representing a quantised
intensity value. A bitmap is a simple information matrix describing the individual dots
that are the smallest elements of resolution on a computer screen or other display or
printing device.

Animation is created from drawn pictures and video is created using real time Visuals.
Animation is possible because of a biological phenomenon known as persistence of
vision. The different techniques used in animation are cel animation, and morphing.

7.17 ANSWERS TO SELF CHECK EXERCISES
1) Multimedia is the field concerned with the computer-controlled integration of

text, graphics, drawings, still and moving images (Video), animation, audio, and
any other media where every type of information can be represented, stored,
transmitted and processed digitally.

A Multimedia Application is an Application which uses a collection of multiple

Multimedia
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media sources e.g. text, graphics, images, sound/audio, animation, movie clips,
and/or video.

2) Text, graphics, images, audio, video, animation etc.

3) Some of the major applications of Multimedia are: -
a) To create Computer Based Training.
b) To create interactive web contents with sound and movie files.
c) To create Multimedia presentation for marketing and promotional aids.
d) To create informative Kiosk etc.,

4) (a) True (b) False (c) True (d) True (e) False

5) A high end PC/ workstation with a reasonable VRAM, RAM and CD-ROM
Drive and Speakers as for as Hardware is concerned. The basic required
configuration is: RAM- 1 GB minimum, SPEED-1 GHz, STORAGE- Depending
on the work your doing you may require anything from a 10GB available space
upwards. For the software any image editing software like Adobe PhotoShop,
animation software like 3D Max or Blender, some sound editing software like
Sound Forge or Audacity and lastly Authoring software like Macromedia Director.

7.18 KEYWORDS
FireWire : A standard high-performance serial bus for

connecting digital devices together or to a
computer.

Hypermedia : An extension to hypertext providing multimedia
facilities, such as those handling sound and video.

Hypertext : A software system allowing extensive cross-
referencing between related sections of text and
associated graphic material.

Pixel : Abbreviation of picture element  refers to a
minute area of illumination on a display screen,
one of many from which an image is composed.

Raster graphics : A dot matrix data structure representing a
generally rectangular grid of pixels, or points of
colour, viewable via a monitor, paper, or other
display medium.

Vector graphics : Use of geometrical primitives such as points, lines,
curves, and shapes or polygons—all of which
are based on mathematical expressions—to
represent images in computer graphics.
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